Your WTFs and frustrations in Void


#320

No one has that problem with Firefox?
For example if I right click in any link, it will open a new tab after displaying context menu for a millisecond. It’s the main reason I switched to Chromium as a fall-back browser. And I’m fairly sure this behaviour is exclusive to Void.

@unixsheikh, I’m more concerned with the time it sometimes take to review new or even update the existing package. At least for errors there are places to look.


#321

@eichhorn
No problem with firefox here??


#322

That’s strange. Here’s a gif. I’m not pressing the left mouse button at any time here. The moment I let the right mous button go, it “clicks”.

Interestingly enough, if the context menu opens upwards relative to the cursor, this does not happen.


(Erin) #323

@eichhorn, it seems you are not the first nor will be the last. A quick search on this forum found this (although it doesn’t solve the problem but I seem to remember this being brought up in the last few weeks (could be that post) but no issues have seemingly been raised on GitHub.

Quick search on the 'Net reveals this which suggests theme could cause a problem. Worth a read!


#324

Thanks!

That didn’t help but at least now I know that I’m not alone with this problem and that it probably has nothing to do with Void.


#325

The only thing that has given me problems so far is the Gajim plugin installer. Also, maim doesn’t work for me either.


#326

@Nurrm maim ? it works fine on x86_64-musl. :neutral_face:


#327

I have no idea. I have x86_64-glibc and this happens every time I try to use it.


(maxice8 alter) #328

locale not properly set would be my guess.


#329

oh yes I see now! the same for me, if I run maim with no arguments:

$ maim
89�$���/�VeJFP�8o<x�N�V�]�����%M��<���%��\Y<f�fXײ���&\��g���V�Z�Z؊��B�~3\��c�/f�©��'5&�|&�q��,T4y�	�ulI9�B��,����ν^|;���Cs���Ϧz�8��	��ҞA��H�'���	D�E^l^�1	!�!�B<(�M�ZXX����F��¢�g\U�\}w�d��S�܏���h���5ib56v=~~oӷo��;IM=FT�*�����v�ֶAA3	
���xrJէ���v���.��$���R�h߶5o�7���xbb��о�A���˥^ת��f].-�Ύ�'U+0�ڵ{�{��h��R�W������C�a�cϥ//�Z�+ҡ-�R�_|\�����Ԡ���X�[c[ϖ��A�
                                                                                                                         2XW�S<����%ֵ�I?��_�e��:�t���r���m?�{�c�a��B����GR�ڮ������G߈�$�L$�X*Q��ȏ�7*�J��1H;�p
>+�:!=$���)�X�(f_�k���8��r(���7,����C��;0-�3�w�T=%�S[�eG|���k��~y��D���
[...]

:fearful: ?? lol

However, if I run:

$ maim ~/screenshot.png

it works! :sweat_smile:


#330

Thank you. I also solved the other problem by installing the plugins manually. No complaint for now.


(maxice8 alter) #331

well, it is sending the png image to stdout, no wonder it is garbling up the terminal.

do

maim | xclip -selection clipboard -t image/png and you will have a screenshot of your desktop in your clipboard.


(Jacob Moen) #332

A major frustration that I have is that I can’t think of any Void WTFs to add to this topic :smiley:

I am always aware that I am using an unstable, rolling distribution when I use Void.
However, as rolling distributions goes, Void is in my experience refreshingly rock solid and surprisingly stable.

Yes, from time to time we face the problem with nVidia and the kernel falling out of sync, and occasionally we get hit by Qt/KDE update cycle, but other than that … and that’s not really specific to Void … I can’t point a finger at any Void specifics to complain about. :grin:


#333

Restricted packages have to be managed by xbps-src. Updating packages with xbps-src and xbps-install is a pain in the ass.


#334

Up to now, didn’t know what to post here, but recent messages on twitter about important stuff changed my mind…
C’mon, twitter?? Really??
What about us that don’t use that kind of crap?


#335

@pin
Add a firefox live bookmark of this rss feed for voidlinux twitter stream:
https://twitrss.me/twitter_user_to_rss/?user=voidlinux


(Jacob Moen) #336

Wouldn’t it be better if the Twitter feed was mirrored here at the forum?


(Edmond Dantes ) #337

You could also consider using a Mastodon instance instead (just saying) :wink:

I didn’t know twitter provided XML/RSS2 feed for users. That’s quite nice, already added to newsboat :smiley:


#338

@pin I personally don’t pay any attention to what happens on twitter. :joy:


#339

shlibs. Especially when I’m just trying to recompile something with xbps-src.

Rather heavy chromium patching. This means that I can not simply change one digit in the template and update it. Maybe I should give Firefox+sndio another try.