Home | News | Download | Packages | Forum | Wiki | Github

Your WTFs and frustrations in Void


(Mitchell) #279

Probably overkill, but nouveau was blacklisted on both the kernel command line, and in /etc/modprobe.d, nouveau was not installed either. I did reinstall Nvidia a few times as well lol.
lsmod | grep nouveau confirms it’s not loaded.

My xorg.conf looks like this:

Section "Module"
        Load "modesetting"
EndSection

Section "Device"
        Identifier "nvidia"
        Driver "nvidia"
        BusID "1:0:0"
        Option "AllowEmptyInitialConfiguration"
EndSection

I’ve also confirmed the bus id is identical with:

lspci | sed -ne'/NVIDIA/s/ .*$//p'

and I also have a startup in my xinitrc

xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

I’m at a loss as to where this issue could be coming from.

I should also note that Nvidia drivers work absolutely fine on my regular workstation with an Nvidia 1070, my laptop has a hybrid graphics setup that’s most likely complicating the issue. Still strange though how it works fine in Arch, and Ubuntu for that matter with identical configurations.

No worries :slight_smile:

EDIT: Probably should note that I’m not too concerned with the Nvidia issue as I’m able to boot multiple distros from my zpool, if people are really interested in helping me solve it I can create a new topic for it.


(Edmond Dantes ) #280

This has a high chance of being your problem: why would you load modesetting if you have nvidia closed-source driver? what would modesetting serve for since no KMS driver is available,being nouvesu blacklisted?

I’d remove that module section completely, or better replace “modesetting” with “glx”. Also be sure you uninstall xf86-video-modesetting in case it was installed,as I huess,or Xorg will try to grepodesetting prior to nvidia and subsequently fail. Also, having a partial xorg.conf file like this is not good: either write a complete,all-including one, or copy the nvidia-related stuff to a /usr/share/X11/xorg.conf.d/20-nvidia.conf


(Mitchell) #281

I have both Intel and Nvidia drivers loaded.

From a working system:

mitch@sager /home/mitch $ lsmod | egrep '^(i915|nvidia)'
nvidia_drm             45056  2
nvidia_modeset       1110016  2 nvidia_drm
nvidia              14364672  93 nvidia_modeset
i915                 1908736  3

For what it’s worth, running that on Void gives me the same output.

Sure the xorg config could be a problem. But then why would the identical configuration work on other distributions, without issue? For reference I’m not the only one using this kind of configuration:

https://wiki.voidlinux.eu/Proprietary_Video_Drivers
https://wiki.archlinux.org/index.php/NVIDIA_Optimus#Using_nvidia


(Edmond Dantes ) #282

sorry, again, I had been too quick in reading and remembered about you running Optimus only afterwards. I’ve never had any of those GPUs, so have no clue about that, is the driver version the same on the other distros? Indeed an identical xorg.conf, with the same set of modules loaded, shoud virtually result in the same behavior. My only guess is a missing xorg library, or a different initramfs resulting in some conflict. What if you opened an issue on github?


#283

The packages! There are no packages in the repo! My fonts, ftp apps, utils…

Hmm, my experience is opposite.

I got a ton of nice fonts installed by default, I found almost every utility I needed, and fresh. (FTP apps in 2018 when you have scp and rsync? Why use that protocol at all, beyond maybe tftp for firmware updates of embedded devices?)

Also, the few missing binaries I did not care to compile I was easily install form Debian / Ubuntu packages (mostly PPAs anyway).

Distros are by necessity opinionated: e.g. Debian is “rock solid but last year”, Arch is “freshest but some assembly required”, Alpine is “super compact, but basic necessities only”, etc. Find the one that fits your needs; there’s no “one size fits all” distro.


(Ioan) #284

https://github.com/mailpile/Mailpile/archive/1.0.0rc2.tar.gz sorry i am late xD


(Gus Fun) #285

Please tell us how exactly do you install a *.deb into void. Do you just open the archive, take the binary out and place it into /usr/bin or /usr/local/bin and chmod it as an executable? In most cases there are needed libraries and such, do you copy paste everything needed to make it work? It worked, I assume!
And you keep notes of what you have done and watch for updates and redo it all again? Or do you actually have a debian installation on the next partition and update it and copy paste from one partition to the next?
It is all linux after all.

I have started an experiment in a new machine I got, a new old machine I got for next to nothing, where I have 5 different installations of linux, all non-systemd systems, that share some resources, such as /usr/share, /var/cache/, /tmp, /opt, and see when and if there would be problems with this practice. So your hacking is of interest to me. For example I installed palemoon once, and it is running on all installations without any replication. My /home/ is also a maze.


#286

may be, my installation is too simple: only lxde. Never hat any problems with -Syu. Compared to Paldo linux I find the syntax of xbps too complicated.


#287

I’m pretty sure this question has been raised earlier.
Use the search function of this forum. :wink:

well, if you say so… use aliases then? :slightly_smiling_face:


(Gus Fun) #288

Was your career in customer service? Did you get bonus for unloading the most hits?
Do you have answers for everything?

I’m just giving a hard time, I don’t want to disrupt your microcosm.


#289

Regrettably no. :pensive:


#290

For some reason Firefox on Void has a strange RMB behaviour.
If I click it normally, it seems to perform a double-click, opening new tabs and what not.

Anyone knows what may be causing it and how to fix this?

I have a clean profile on a newly configured system. Mouse is also new.


(Erin) #291

Sarcasm and hitting people who help… nice.


(Gus Fun) #292

What, we can’t even joke around with “people that help”? Are they above human?
People that help also delete your messages just to show you who is boss around here. I see @cr6 as someone with an axe, not necessarily one with a helping iron.

Seriously, some of you treat a distro’s forum like it is a customer service counter and only those behind the bench can help and none dare speak badly about the men behind the counter.


(R.J.) #293

I believe it’s grub, I had a similar issue back then when for whatever reason I tried to manually install nvidia drivers (absolutely broke my install, never again)
Add rd.driver.blacklist=[Driver you wich to blacklist]
to the GRUB_CMDLINE_LINUX= line in /etc/default/grub

and then, run grub-mkconfig -o to generate a new grub.conf file, iirc


(Erin) #294

@fungalnet suggest you read https://forum.voidlinux.eu/faq and the associated pages.


(Edmond Dantes ) #295

@fungalnet I think you possibly misunderstood @cr6’s tone, maybe something’s been lost in translation, but either way, if you feel you’ve not been treated in a proper manner, then there are PMs, and there are report flags. The forum is not a suitable place for plublic mocking

@Erin has given you the best advice he/she could come up with: read the FAQ. That’s the first thing I did months ago and the first thing every user should do. Explicitely addressing and criticizing users is forbidden.

@cr6 is arguably the user to contribute most to this forum, and gives his best to help people, while asking for nothing in return, with a humilility, a self-irony and a kindness which are extremely rare to find on online fora in general, especially tech/Linux fora.


#296

I believe there was a genuine misunderstanding.

As a moderator, deleting posts that were flagged is part of my job.
It’s not against you, @fungalnet .
I always send a PM to explain why I delete a post (even if there’s no obligation to do so).
I guess another moderator would take a different approach in comparable cases.
I can understand your frustration when you don’t agree with me, it’s human after all…
Different people see things differently - different viewpoints.

If you don’t like the way I’m doing things, you’re free to contact IIRC the real bosses, to complain about me (that is not meant at all ironically).

You enjoy the rest of your day.


#297

The package elogind in it’s current state.

why? I invested hours because my tmux sessions were closed on ssh logout. This isn’t the behavior one does expect without changing things. Nothing I found helped.

Until I looked at /etc/pam.d/sshd noticed the file elogin-user at the same level. Out of curiosity I looked up what elogind actually is and came to the conclusion, that it is kind of a compatibility layer for systemd dependencies.

It was a pure coincidence that I noticed (during my search) users complaing about systemd killing the processes on ssh logouts. So I looked at /etc/elogind/logind.conf and see the default value (which can apparently be changed during compilation):

KillUserProcesses=yes

Yep that was the root of the issue.
That happened after a huge update (which probably pulled elogind) and I had not the slightest hint.


(Gus Fun) #298

OK, I misunderstood, my fault, end of story. I never liked moderation in open forums anyway, and on one I was made into a moderator I quit the first time someone else moderated something without consulting the rest. In general I have a serious issue with this action. Sometimes you can contact someone and express your discomfort with something they wrote and they may decide to moderate themselves.
Perceptions are like @holes, every one has one, except for some colon cancer patients.