Home | News | Download | Packages | Forum | Wiki | Github

Your WTFs and frustrations in Void


Some random suggestions:

  • add categories to the templates
    for example if I want to test some new filmanagers or terminals, it would be nice if xbps-query could display a list of forexample gtk,filemanagers.
    This could also be used in the installations medias installation script, to for example display available boot managers, on a net-install.

  • set the forum default to “Categories”, you can still see the latest post on the right side still.

  • choose some less bright background for the forum, it kinda hurts the eyes.

$ xset
usage:  xset [-display host:dpy] option ...
    To control Energy Star (DPMS) features:
	-dpms      Energy Star features off
	+dpms      Energy Star features on
	 dpms [standby [suspend [off]]]     
	      force standby 
	      force suspend 
	      force off 
	      force on 
	      (also implicitly enables DPMS features) 
	      a timeout value of zero disables the mode 
    For screen-saver control:
	 s [timeout [cycle]]  s default    s on
	 s blank              s noblank    s off
	 s expose             s noexpose
	 s activate           s reset
    For status information:  q



Yes, checked requirements-dev.txt

Seems like selenium>=2.40.0 is not available in Void repos.


Mm yes, But I’m still not shure of how to manifest this.
In Another thred I remember I saw that you had to put “xset s off” in xinitrc and reboot the X server…
so I put this in /etc/x11/xinit/xinitrc.d/screenblankoff and chmod it

it still did not help tho. :confused:

but but but! :smiley: … I think I see my problem now, it misses “.sh” :smiley:


@Shampoo It’s quite simple: using xset s off your turned off the screen-saver, but you also need to turn off the DPMS features: xset -dpms

You can see your current settings with: xset q


alright, i will remeber that if it fails this time. but i dont remeber that I didn’t have to do that last time. so now we just wait 10 min, and then I get back with the results :wink:


No, as long as your script is executable, you don’t have to add .sh


mm we are both right
the screen still blanked, so it perhaps needs the "xset dpms"
but it do still need “.sh” looking in the /etc/X11/xinitrc file on the for loop

if[ -d /etc/X11/xinit/xinitrc.d ] then
for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do


still didn’t help, still blanks :frowning:


No, the .xinitrc file that is present on the live ISOs is not like that.

It’s like that:

[anon@void-live ~]$ cat .xinitrc
# ~/.xinitrc
# Executed by startx (run your window manager from here)

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  unset f

As you can see, it does not refer to any .sh

EDIT: It’s intriguing… :thinking: I opened a new issue about this.

EDIT2: [SOLVED] Fortunately, Duncaen knows everything about Void! :sweat_smile:

(oliver) #229

I like this idea a lot. Back in my Gentoo days I found a lot of useful packages just by looking at the portage tree (although that’s a different way to do it, the end result is similar)


:expressionless: And if you run: xset q

What do you get? (Post the output if you want)

You should see: Screen Saver timeout: 0 and DPMS Disabled

Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  600

DPMS (Energy Star):
  Standby: 600    Suspend: 600    Off: 600
  DPMS is Disabled

If one of them is not disabled, just use one of these commands:
xset s off
xset -dpms

It’s quite simple.

(Ioan) #231

according to the dev’s is stable the last release


@Ioan please, where is the release tarball ?


For some reason, Void runs fsck.f2fs on every boot and it becomes slower every time.
Shouldn’t it be only once in N launchers or after the sudden power failure?

I turn the system down using the poweroff command.


is part of f2fs-tools package:

$ xbps-query -f f2fs-tools

Take a look at: /etc/runit/core-services/03-filesystems.sh
The relevant part:

# vim: set ts=4 sw=4 et:

[ -f /fastboot ] && FASTBOOT=1
[ -f /forcefsck ] && FORCEFSCK="-f"
for arg in $(cat /proc/cmdline); do
    case $arg in
        fastboot) FASTBOOT=1;;
        forcefsck) FORCEFSCK="-f";;

if [ -z "$FASTBOOT" ]; then
    msg "Checking filesystems:"
    fsck -A -T -a -t noopts=_netdev $FORCEFSCK
    if [ $? -gt 1 ]; then



How can I ensure to be in fastboot mode upon boot?



$ man shutdown

     -f      Enable fast booting; skip fsck(8) on next boot.

     -F      Force run of fsck(8) on next boot.

:coconut: Another solution may be to use /etc/rc.shutdown , to add something like:

touch /fastboot

It will create a file /fastboot every time you reboot or shut down your machine.


That’s one of things I like about Void the most, package splitting.

(maxice8's favorite salad) #238

oh lol no thanks i don’t need a package of development headers bigger than the actual package itself.