Your WTFs and frustrations in Void


(Erin) #199

The command line is a wonderful thing. Try this link.

It is also possible the GUI failed if the correct tool was not installed i.e. bzip2 for .bz2 files.


#200

Yes, xarchiver works fine. :slightly_smiling_face:

But, of course, you must install bzip2, xz, zip, unzip, p7zip to be able to extract these archives.

Go to Edit -> Preferences -> Advanced -> Archiver integration

And you can select the one that you want…


#201

Yeah, like screenFetch. Which installs /usr/bin/screenfetch. It bugs me that the package name / executable don’t match case. I know that’s not void’s fault, but void is one of the few to ignore that.


(seth) #202

not directed at cr6 specifically but i highly recommend wifish for anyone using a laptop or switching wifi networks often, but without the use of a gui tool. it’s in the main repo and maintained by a community member.

make sure to edit the wifish script once installed to point at your wireless interface if it’s not already.


(rain1) #203

Separate -devel packages… oh hell no


(Gus Fun) #204

I was given a challenge, to install void for someone but it had to be able to run Plasma on it.
Little that I know about it, I only use openbox a little of LXDE, I did an installation of all the KDE and Plasma crap I could find in the repository. Then I tried to see how to get it started. Then I gave up as I know little about it. I can’t seem to find an easy explanation on the forum, or whether plasma actually works now.
Can you run plasma without a DM? If not, is lightdm the ongoing proffered DM? They might need a DM if they want to be switching from one account to another.

I had no idea that KDE runs on top of openbox and Void has a KDE-ob script to configure it. So I may be close to understanding how to. Start ob-kde and then start plasma? If it works make all this autostart?


#205

KDE Plasma can use different window managers like openbox, but by default it uses kwin, using a DM you can select which window manager to use.

  • First install the kde5 metapackage. If you don’t need a DM just run xinit /usr/bin/startkde
    (To use openbox instead of kwin use xinit /usr/bin/openbox-kde-session)
    (Or by using an environment variable export KDEWM=/usr/bin/openbox-session && xinit /usr/bin/startkde)

  • If you do use a DM (Any DM should work), start KDE by selecting Plasma
    (To use openbox instead of kwin select KDE/Openbox)

I need to get round to expanding the wiki page on KDE to explain all this as well.


(Gus Fun) #206

Thank you. I am not on that machine now, I may get to it sometime tomorrow and I will try where I left it at. I may be missing some kde part.

Tangent --> if you only have one de installed, openbox for example, would xinit alone start it? Or is it some etc/…rc file where the default DE is set?


#207

Yes, a line in your ~/.xinitrc file:

exec openbox-session

And run xinit

Note: I usually run startx instead of xinit , I don’t know precisely why. :black_joker:


(Gus Fun) #208

Thanks a ton
You have cleared out much of confusion, both of you.
I confuse the startx and xinit and between the 5 systems I am running each has a different setup from all others. I need to review it all and make it more uniform.

My preference is what I have with void now, no DM, just openbox starting with xinit with no root rights necessary. But this is for me. I hate looking at my ~/ and it being more complex than /etc

With other systems I had to do much more work to simplify it to this point.


#209

I’m currently using openbox in Void and Devuan with the same setup…

EDIT: and the same setup for fluxbox in Void and Debian ! :grin:


(Scott Robbins) #210

Using startx runs a script that does a little more. It also (at least it did, haven’t checked in awhile), requires hostname -f (FQDN) to be working, otherwise, it hangs for awhile. If startx hangs but xinit starts X immediately, that’s usually the issue and can be fixed by putting the localhost name in /etc/hosts.

The ArchLinux wiki has a script to run multiple desktops. I made up my own lame one that I’m embarrassed to share, but it works for me. :slight_smile:


(Gus Fun) #211

So when runit needs the hostname it reads it off of /etc/hostname or is it set in runit as well?


#212

@fungalnet it reads it off /etc/hostname , but a hostname declared in /etc/rc.conf is also possible:

# /etc/rc.conf - system configuration for void

# Set the host name.
#
# NOTE: it's preferred to declare the hostname in /etc/hostname instead:
# 	- echo myhost > /etc/hostname
#
#HOSTNAME="void-live"
$ cat /etc/runit/core-services/05-misc.sh
[...]
[ -r /etc/hostname ] && read -r HOSTNAME < /etc/hostname
if [ -n "$HOSTNAME" ]; then
    msg "Setting up hostname to '${HOSTNAME}'..."
    printf "%s" "$HOSTNAME" > /proc/sys/kernel/hostname
else
    msg_warn "Didn't setup a hostname!"
fi

(Ioan) #213

i will add a wtf to the list

mailpile void package is 0.5.2 while last stable release is 0.99


#214

Are you sure about that? :thinking: I can’t find 0.99 in Mailpile/releases.


#215

I guess @Ioan is referring to this page: https://www.mailpile.is/download/linux.html
But it states:

Note that the release candidate packages have version numbers in the 0.99.* range.

So it isn’t the actual stable version. Hopefully version 1.0.0 will be released soon.


#216

@bluemoon In the meantime, I tried to update the package: here’s the template, but I got errors during the build (log) :frowning_face:


#217

@cr6 Did you check the requirements*.txt files in the source tarball? Do you have all dependencies?


#218

The hard drive on my laptop crashed a few mounts ago, so bought myself a new laptop, (just in case it was something else that crashed). The new laptop unfortunately had/has a wifi-card that is only supported in the latest kernel, so i have been distrohopping for a while now. Until I finally gave up and bought myself a new hard drive to my old laptop and returned to try void again.
This time i had a notepad at hand beside me, to note when i got stuck on some WTF moments.

And i must say, void is a dame good distro, (otherwise I would not return)
But these are the things I had written down.

  • Still no rfkill on the installation media.
    (needed to unblock my wificard)

  • rfkill is moved to the util-linux pakage, wits in its turn is dependent on 5 other packages.
    (libsmartcols, libuuid, libblkid-2, libfdisk, libmount)

  • xbps-install cant install stuff that is right in front of you ( ./ ).
    (had to use xbps-rindex)

sudo xbps-rindex -a /path/to/dir/*.xbps
sudo xbps-install -R pathto/dir/ name_of_pakage

  • xbps-install does not accept the full name of the package file
    (.xbps)

  • firefox on the installation media does not work.
    (he complained about some security issue, maybe it doesn’t accept my wifi connection?)

  • installation media has no wget.

  • wget got the error:
    Error: The certificate of ‘repo.voidlinux…” is not trusted
    ‘repo.voidlinux…’ is not activated
    The certificate has not been activated.

Solution:

wget --no-check-certificate

  • wpa-supplicant is already running wish prevents me from connecting.
    (I use my mobile phone as my wifi source, so it is not always present)

Solution:

rm var/service/dhcpcd

  • xbps-install -Suy got the error
    SSL_connect returned 1

explanation and solution.
For some reason the date had bin set to 2016 something something…

date –set=” sat jan 20 14:05:00 CST 2018”
hwclock -w

  • the root acount is set to use sh as standard shell (I actually kinda like that this is the default for some reason, even tho I change this to bash)

solution:

vi /etc/passwd
change
root:×:0:0:root:/bin/sh
to
root:×:0:0:root:/bin/bash

  • screen blanks after 10min.
    Still no solution for this one. “xset s off” does not seem to work.