Home | News | Download | Packages | Forum | Wiki | Github

Your WTFs and frustrations in Void


(Jakub Skrzypnik) #1

Let’s post some things you find uncommon in Void Linux, compared to other distributions, what makes your head blown. Only related to core distribution and packages, if you want to complain about some 3rd party package, consider posting it on our Issue Tracker on Github, unless it’s really weird.

I’ll go first:

  1. more as $MANPAGER in default installation… seriously, why?
  2. Why this installer still exist? As installer, it should help you with installation, but It’s always painful for me to fight with that dialog-ized crappy script. Network detection doesn’t work well, you cant’t select a “Network” as an installation source if you’ve configured network externally (like I always do in second tty), I’ve almost destroyed my disklabel once using that awful “filesystems” menu, and so on… Can we just deprecate it in favor of “bootstrapping”?

Post your own crazy findings in Void, and please don’t take this topic too seriously.


(Andy Mender) #2

I’m actually pretty optimistic to use Void Linux and I don’t see the many problems I usually encountered in openSUSE, Ubuntu or Fedora. That being said:

  1. The installer, somewhat. If I select the ‘no bootloader’ option, I mean it. Don’t install GRUB2 for me, please :P.

  2. xbps synthax. I thought separating apt into apt-get and apt-cache was funny (hence. I used aptitude). xbps-install, xbps-query, xbps-remove. Too much writing! I know I can alias the commands, but still. Also, the 1-letter options are pretty confusing. I’ll get used to them, though :).


#3

The “live” cd should provide the same installed environment as it provides booting from it,

Its more than a little disapointing to be reboot to a basic shell (sooo last centry :wink: ) with almost nothing installed

a right PITA if you only have wifi networking… (and beyond a none technical user - but I assume you are trying to avoid none techinical users) the installer network setting for wifi doesn’t seem to actually do anything…

Surely the cinnamon"live" cd (for example) should install those few extra package selections to bring up the same from the HDD

for live images with any kind of X environment, what wrong with using zenity ? (and fallback to curses only if X-less)


#4

Thats just because more is part of coreutils, just install something else and set $MANPAGER, I don’t see why its a problem.
Its not the default $MANPAGER, its not set. man just falls back to it because its the only one installed by default.

If you choose local instead of network installation, the whole live image is just copied and you will have the same environment.


#5

If you choose local instead of network installation, the whole live image is just copied and you will have the same environment.

This really needs to be much more obvious - its probably driving hordes of people away!

… on the other side of the coin

Stuff I like

Its not systemdOS (why so many distro decided to merge who knows! :o) )
well (and elegantly) engineered
simple fast package manager (i might write a simple gui front end!)
not bloated


#6

#7

@Duncaen spoil sport :stuck_out_tongue:


(Benjamin) #8

I had a similar problem.


(deepdark) #9
  1. print to pdf is horrible - first distro in years I need to do something to fix that - haven’t done it yet, and havent done it in so long I cannot even find my notes on it. I’ll have to get to it soon. Maybe it is not Void related at all. File as learning experience.

    EDIT: silly me. 3rd party sw not yet installed. Problem solved.

  2. xbps syntax is a bit ornate to me. But I’ll get there. File as learning opportunity. Here’re my aliases in case anyone finds `alias xq='xbps-query -Rs’
    alias xqr=‘xbps-query --regex -Rs’ ; use like so: xqr "flash.*chips"
    alias xu='sudo xbps-install -Su’
    alias xi=‘sudo xbps-install -S’

`3. dracut warning :slight_smile: have to exit out before I can log in. It’s ok though since anyone who starts the computer would think it won’t work. An annoyance, but also, kinda humorous. File as non sequitur.

From my perspective, Void is mostly frustration free. Likes.


#10

I ran into some of these issues during my install. I thought the livecd would install the DE (Mate) in my case, instead of bare minimum system. I did read something about do not choose network, the first time but couldn’t find the message again to see exactly what it meant. I had to do a second install and chose network, I borked the first install and I did choose local.
I made some alias for the xbps commands, too long using original commands. Other then that, everything else went pretty smooth.


#11

PermitRootLogin is set to yes by default in /etc/ssh/sshd_config . I would hope that my LAN is secure, but I don’t want to put trust into it :slight_smile:

MANPAGER got me too. @Duncaen : what are your thoughts re leaving ‘less’ out of the live environment? How have you chosen to draw the line on what gets included and what does not?

EDIT: less is not used by default once installed


#12

Some packages in the repos have capital letters, which is annoying to no end. I try to install something, and it doesn’t work, so I have to search the repos online to see what the name is. Example: screenfetch was screenFetch.


(Jan) #13

“Almost nothing installed” is the big advantage of Void. I like that I am not pushed to follow any pre-installed and pre-configured environments. Guys, please, keep it like that :slight_smile:

On the contrary, last time I spent half a hour on Ubuntu just to find out where the motd message comes from. They involve PAM but - why? Why they can’t just write the contents into /etc/motd file? Of course, I can disable it, but can I be sure that it won’t get back after next dist-upgrade?

All these unneeded features make things only worse, unclean and they take time.

Another thing that Void does not - and I like it - is, that it does not start services automatically after installation. It happened to me on Ubuntu once, that something re-installed nginx (probably as a dependency). The nginx was started and served almost one week contents of my www directory, because I have left some configs in /etc/nginx. I didn’t know about it.

I think that predictable environment and no automations is the most advantage for experienced users.


#14

There’s no reason at all there can’t an “engineers” tar ball, and a bootable image that will install I nice minimal (say) xfce installer, that makes a minimal install of a working GUI

  • but your point is well taken a small image that installs just a cli is indeed useful

Ubuntu is a case in point in how to get carried away in infrastructure - almost everything that matches *kit isn’t actually essential… mired in a swamp of dubious PAM entrails and dangerously over powerful dbus abilities and thats before they widened the attack surface and even EFI should be not just mounted (poor practice) but writeable ! pile on a bit more infrastructure and before you know it the whole top heavy morass collapses under its own weight… (phew)

so yes a slim installer is essential but a gui need not make it a bloatfest…!


#15

There are ISO files with preinstalled (and unconfigured) DEs available, so I don’t see a problem with that. Void is nowwhere near a distribution intended for people new to the GNU/Linux universe so there is no need to waste resources on more than that imo.


(epitimizer) #16

The packages! There are no packages in the repo! My fonts, ftp apps, utils… what am I going to do without??! and whats even worse is it’s labeled as a binary distro. This stuff should be built and ready to install. but now left with hunting and compiling as my former distro required. This is unacceptable IMO.


(Benjamin) #17

What do you mean there’s no packages in the repo? There are lots of packages
@epitimizer


(Benjamin) #18

20 posts were split to a new topic: Void spin ideas


(Jakukyo Friel) #33

I consider this a feature.
less is more.


Void spin ideas
(Pork Interface) #34

I just installed the Enlightenment iso on a nettop for testing. After updating and installing a few, very few basic apps like mps-youtube, mplayer, leafpad, google-fonts, I noticed a couple of issues.

  1. Firefox was slow. It was freezing up for several seconds every time I did anything, such as clicking a link, opening a new tab, etc… It was so bad I thought one of my extensions was the culprit, but I doubt it.

  2. After a reboot all of my window title fonts had changed to some goth-looking type. Didn’t affect any other fonts in menus or apps, just the title bars and task bar buttons. Somehow, this odd font was showing up as the regular Sans font. Could have been the google fonts install & this incident would be a first in doing so.

I suppose the Enlightenment spin just isn’t for me. Back to LXQT.