Home | News | Download | Packages | Forum | Wiki | Github

Xfig: All text looks the same until exporting to pdf


#1

Hello,

once again I come to ask how something works because I can’t seem to figure it out…
I like to use xfig to draw figures for things. When I moved to void, I was pleased to find xfig was available. However, after installing it, I noticed that all text looks the same, regardless of size and font selection, until I export the .fig, e.g. to a pdf, where suddenly the text appears with correct size and font.

Launching xfig from terminal results in the message

Warning: Missing charsets in String to FontSet conversion

after which the program starts and behaves as described above.

Searching the internet, I found that it might be the locale (my locale is de_DE.UTF-8), but setting LC_ALL to C, and then launching xfig didn’t solve anything.


#2

Hello @blu132

On my Void x86_64-musl I have the same error:

$ xfig
Warning: Missing charsets in String to FontSet conversion

In the Search Engine I found this page related to the same problem…

Now If I run:

$ export LC_ALL=C
$ xfig

The error message no longer appears !


#3

Note: Compared to the Void package, we can see that the Arch package uses an additional patch called xfig-3.2.5-color-resources.patch

Not sure if we need it for Void ?

The xfig-aspell.patch is already present in the Void template however.


#4

Ok so I forgot to export LC_ALL in my test… Either way, the described behavior remains: xfig does not show font or size of any text. I am also not sure if the behavior is specific to only xfig. Recently I tried to compile and start CDE, and the blue welcome screen had the same issue where font size and font type was wrong. Maybe we are missing some package that renders xfonts?

Edit: I checked what debian lists as a dependency to xfig (it works as expected there) and installed xaw3dg, which xfig does not depend on in void linux. This changed nothing.

I also examined the message box closely while attempting to change various things about text.
Trying to change font size in xfig results in “Font size 20 not found, using smaller 12 point”, e. g. for trying to set the font size to 20.


#5

Take a look at xfig template

configure_args="--without-xaw3d"


#6

I just recently needed to use xfig and am delighted to see that fonts appear to work properly now. Thanks to whoever spend their time fixing this. I’d invite you to a beer, but you are probably nowhere near me. I could mail it to you, though.