Home | News | Download | Packages | Forum | Wiki | Github

./xbps-src pkg ERROR: [reposync] failed to fetch file on Debian Stretch


(Alessio) #1

Hi,
I’m trying to run the ./xbps-src pkg inside debian stretch x86-64 but I get the following error messages :

alessio@Alessio-PC:~/Develop/Temp/void-packages$ ./xbps-src pkg tvheadend
[*] Updating `https://repo.voidlinux.eu/current/musl/x86_64-repodata' ...
ERROR: [reposync] failed to fetch file `https://repo.voidlinux.eu/current/musl/x86_64-repodata': Not Found
[*] Updating `https://repo.voidlinux.eu/current/musl/nonfree/x86_64-repodata' ...
ERROR: [reposync] failed to fetch file `https://repo.voidlinux.eu/current/musl/nonfree/x86_64-repodata': Not Found
[*] Updating `https://repo.voidlinux.eu/current/x86_64-repodata' ...
[*] Updating `https://repo.voidlinux.eu/current/nonfree/x86_64-repodata' ...
[*] Updating `https://repo.voidlinux.eu/current/aarch64/x86_64-repodata' ...
ERROR: [reposync] failed to fetch file `https://repo.voidlinux.eu/current/aarch64/x86_64-repodata': Not Found
[*] Updating `https://repo.voidlinux.eu/current/multilib/x86_64-repodata' ...
[*] Updating `https://repo.voidlinux.eu/current/multilib/nonfree/x86_64-repodata' ...

Is there some repository server that doesn’t work at the moment ?

I’ve seen the same error message on the Travis Ci when I sent my pull request(https://travis-ci.org/voidlinux/void-packages/jobs/272085931), but while inside the travis it goes ahead, in my machine it stops .

Please le me know, thanks .


#2

I have always gotten these errors as long as I have been using Void. They have never stopped me from doing any packaging though, so I ignore them.

What sort of Void system are you running? i686/x86_64? glibc/musl?


#3

I think the default chroot style doesn’t work.

Use xbps-uchroot with the xbuilder group or proot if your kernel doesn’t support CONFIG_USER_NS.