Home | News | Download | Packages | Forum | Wiki | Github

Wayland and weston under Void Linux


#1

I have been reading about Wayland and weston as a future, faster replacement for X11. But Wayland seems to be associated with systemd somehow (Depends on? Partially depends on?).

Of course I would like the benefits of Wayland, but if I was forced to choose between Wayland (systemd) and X11 (runit), I would stick with X11 (runit).

Am I wrong? Can we benefit from runit and Wayland at the same time? If so, can anyone post a step by step tutorial to switch from X11 to Wayland under Void Linux?


(Vocivus Maximus) #2

Hi @monacci, I am only an interested observer, not an expert.

Short answer : Technically no, there is not a hard dependency (yet) but the interdependence of so many packages/processes on SystemD one way or another makes it increasingly difficult to avoid it.

Put another way, any Red Hat developed project assumes the prescence of SystemD and therefore requires downstream to engineer plumbing around the assumed functions of SystemD if downstream chooses to not use SystemD.

https://blogs.gnome.org/ovitters/2013/09/25/gnome-and-logindsystemd-thoughts/

The good folks at DragonFLY BSD have ported Wayland to their OS. It can be done.


#3

Thanks to Vocivus for his reply. I’m using Void’s musl version besides, and a minimal window manager (jwm), but in case there is a solution, perhaps someone with better know-how than mine could point out what next steps should be done next, or changed, from this entry in Void Linux’s google groups forum. I basically tried following similar steps, but using the mininal Archlinux weston.ini version for the Weston compositor.

It seems from Arch’s wikipage that you can try the Weston compositor while running an X session, simply by running the following within a terminal:

weston

I then got an error message, however, stating in part:

Old Xwayland module loading detected: Please use --xwayland command line option or set xwayland=true in the [core] section in weston.ini

So I tentatively tried:

weston --xwayland

…which still gives me an error:

fatal: drm backend should be run using weston-launch binary or as root

I don’t know how to solve all that.