Virtualbox running on void


(Gus Fun) #1

I have maintained several debian and arch based installations (without systemd) and void. Using virtualbox on all of them there are always glitches here and there, sudden freezes and crashes. Not on void. Void is the best virtualbox experience I have had and since only problems usually get reported here I thought writing this as a thank you note was a good idea.


#2

Preach it, brother. Last week I tried installing Ubuntu on another partition because I need to release a game on Steam and I wanted to test it with the only linux distro officially supported by Valve (well, there is SteamOS too, but that doesn’t count).

Then I wanted to try it on Windows 7, but since I’m not installing that shit on my hard disk, I decided to use VirtualBox. “I’ll just install it on Ubuntu, surely it will be well supported by the most popular linux distro, right?” Oh boy…

Systemd wouldn’t let me load the kernel modules needed by VirtualBox. I tried everything, literally everything, but I couldn’t do it. Apparently, it’s some kind of compatibiliy problem with some laptops that prevents it from loading certain kernel modules.

So I rebooted into my void partition and voilà, it just werks. Shame that VirtualBox doesn’t support musl, though.


(Gus Fun) #3

Have you checked that your bios is not restricting some virtualization capabilities that the kernel is picking up on?


#4

… and don’t forget if you run a website or personal blog, Void makes an excellent server, I’m so happy with void on my VPS I say prominently that the site runs on Void Linux…