Home | News | Download | Packages | Forum | Wiki | Github

Various issues for new user


#1

Hello,
I just installed Void on a spare partition but run into a few problems so I’ll bundle all my questions here.
1 - The login doesn’t work. If I enter the username and user password I used during the install nothing happen. I tried to login with the same username and password in text mode and it seems the username wasn’t registered.
If I login as root, nothing happen unless I click on reboot (weird), then I get into xfce.
2 - If I login as root and configure the keyboard with xfce, still the arrow keys do not work properly in the shell.
3 - Since my laptop use broadband drivers for the wifi, I did the following:
A - Downloaded the broadband driver from Void repo and put it on a USB.
B - created the directory /opt/pak/broadcom-wl-dkms-6.30.223.271_6.i686.xbps
C - #xbps-rindex -a /opt/pak/broadcom-wl-dkms-6.30.223.271_6.i686.xbps
D - #xbps-install --repository=/opt/pak/broadcom-wl-dkms-6.30.223.271_6.i686.xbps
Still I get message xpbs cannot find package in repository.

4 - I tried to configure the wifi manually but when I enter the command:
#ifconfig
I get the message
#sh. command not found.

I have read the wiki but couldn’t find the answers to my doubt.
Void seems a cool distro, I just need to find my way around it.

Thanks.


(Michael Aldridge) #2

The username issue is a known problem with the current installer ISOs. Create your account again using useradd and it will persist.

You cannot log in as root to the graphical environment, this is intentionally unsupported.

I’ll assume you meant broadcom instead of broadband, your commands are correct with the exception of step D, you need a -S in there to tell xbps to read the repodata file you generated in step C.

There is no ifconfig on the system by default as net-tools is deprecated. You can use iproute2 instead.


#3

Initial networking config is a little complicated. See this for help:
https://wiki.voidlinux.eu/Network_Configuration


(oliver) #4

The default shell for root is dash which doesn’t support using the up arrow for the last command retrieval (if that’s what you mean.) It’s probably best to leave root that way and set your own user to use bash/zsh/whatever-you-want


(Avery Freeman) #5

I am just trying out the lxqt-musl live CD in a VM and I can confirm the arrow key “issue”, I believe. It’s the same I’ve seen in other OS, where arrow keys (et. al.) put out strings of characters because they’re not mapped to what we’re accustomed to. For instance, in dash, the up arrow key prints out ^[[A and the left arrow key prints out ^[[D. PgUp is ^[[5~ etc.

I’ve looked for how to fix this as I also experience the issue on other platforms like Solaris and NetBSD, which can also vary from program to program (e.g. vi having the same response while nano being the behavior I’m used to) but I’m a little confused about how to correctly solve the issue.

So you recommend that users set bash, for example, as their personal shell and keep dash for root? I’ve never heard of that before - is there an advantage to having a different shell for root?

Thanks!


(oliver) #6

Not sure I recommend it - each to their own but dash is tiny compared to bash so maybe there’s probably some speed benefit when booting and maybe some security benefits too considering it’s not so feature-rich.


(Avery Freeman) #7

Oh, that’s cool. But how to re-configure arrow key characters to generate movements rather than spitting out garbled strings of text? :slight_smile: I struggled with it on Solaris for ages before I finally gave up… :frowning:


(maxice8's favorite salad) #8

Users can keep their own login shell and keep dash as the system shell ( /bin/sh )


#10

@AveryFreeman
…but if you want to change it…see
http://www.troubleshooters.com/linux/void/voidtips.htm#rootbash

Set root’s shell to bash
Void-installer wisely sets the shell for the root user to sh. This is better for security. So if your situation requires prioritizing security, it’s best to leave well enough alone and skip the rest of thbis section.
For desktop users and experimenters, the big gain in bash usability is often worth its smaller security cost. If that’s your situation, it’s best to switch root’s shell to bash and do it early on. Simply log in as root, edit /etc/passwd, and on the line starting with “root”, change /bin/sh to /bin/bash.


(oliver) #11

You can also use chsh to change your shell. You get the added bonus of the -l flag to tell you what you can change it to