Home | News | Download | Packages | Forum | Wiki | Github

[Solved] Xorg stuck after switching tty


#1

Hi all. First, apologies if this is in the wrong subforum, wasn’t sure if it should be in Applications & Desktop Environments instead.

I recently installed xorg, bspwm and sxhkd. After setting things up, bspwm seems to work fine using startx command. However, when I switch to a different tty (e.g., with ctrl+alt+f2) then back to the original, the Xorg display is replaced by a tty console in which i can input things but produce no response, except with ctrl+z or ctrl+c which puts the process in the background or kills it, respectively. Xorg messages are also produced on the console. Notably, after switching back to the tty with Xorg, this message is displayed last:

(II) AIGLX: Suspending AIGLX clients for VT switch

The full Xorg log is at https://pastebin.com/d1m2Ucyw, my xinitrc is at https://pastebin.com/KHNWSLV8, bspwmrc is https://pastebin.com/069Hjxrx and sxhkdrc is https://pastebin.com/8TFfSgVx.

I don’t think the issue is with my bspwmrc, xinitrc or sxhkdrc config files though as I tried them on another distro which didn’t produce the same issue, so am thinking it could be a driver issue with my void install or maybe issues with the versions of the applications installed?

Anyways, I’d appreciate any suggestions for fixes. And thanks for taking the time to read this.


(Masato the Empty) #2

It sounds like you’re not switching back to the X vty, but to the vty from which you launched X. X will spawn in a different vty from where you launch it. In most cases, that will be #7 (ctrl+alt+f7).


#3

Thanks, that seems to be why it wasn’t working for me. I am curious as to why X spawns in tty 7 in Void though. In my Arch install, when I launch X (bspwm, i3, wtftw) or Wayland (sway), these are spawned in the tty they were launched in. What could have caused the difference?


#4

systemd.

Xorg uses the first free tty in Void and before systemd, if you have the /var/service/agetty-tty[1-6] services enabled 7 is the next free one.