Home | News | Download | Packages | Forum | Wiki | Github

[SOLVED] Void musl - after update ff to 59.0.2_2 I can't run it


#1

Hi,

after todays ff update I can’t run it. I got an error:

XPCOMGlueLoad error for file /usr/lib/firefox/libxul.so:
Error relocating /usr/lib/firefox/libxul.co: _ZNmozilla14AbstractThread17sCurr
Couldn’t load XPCOM.

Thanks


#2

Take a look at Mozilla Support Forum, does it help?


#3

Hey. I got the same problem. Today I installed void-musl for the first time. And firefox won’t run. And not only firefox. Icecat, qupzilla had the same problem too.


#4

@efade I use firefox-esr on x86_64-musl and it works fine, at least. :black_joker:


#5

What firefox version?
I’ve been running Void musl build and firefox, currently on my system, version 59.0.2 with no issues since June 2017 :open_mouth:
EDIT: I haven’t updated my system today. Last update yesterday.


#6

qupzilla and icecat are at least working fine for me. But I have the same behaviour with firefox atm.


#7

New version (firefox-59.0.2_3) of Firefox released that fixes this issue.


#8

Fixed in https://github.com/voidlinux/void-packages/commit/de1b88fcc883668d958de7dcccd67061940fb3c6.


#9

Thank You for your tips guys. I’m happy it is fixed.