Home | News | Download | Packages | Forum | Wiki | Github

[solved] Updating mess with "boost"


#1

When trying to update a month or a two month old system, I get:

boost-1.64.0_2 (update) breaks installed pkg `libtorrent-rasterbar-1.0-1.0.10_2’

I had qBittorrent witch required rasterbar, but I deleted it with dependancies, but this still shows up.
When trying to actually install ‘boost’:

xbps-install boost

icu-libs-59.1_1 (update) breaks installed pkg icu-58.2_1' boost-1.64.0_2 (update) breaks installed pkglibcmis-0.5.0_6’
boost-1.64.0_2 (update) breaks installed pkg libixion11-0.11.1_7' boost-1.64.0_2 (update) breaks installed pkgliborcus11-0.11.2_5’
boost-1.64.0_2 (update) breaks installed pkg libreoffice-5.2.5.1_3' boost-1.64.0_2 (update) breaks installed pkglibtorrent-rasterbar-1.0-1.0.10_2’
Transaction aborted due to unresolved dependencies.

What to do?


#2

What do you get if you run:

$ sudo xbps-install -Su


#3

According to the errors, the libtorrent package is still installed, could you try specifically removing it?

sudo xbps-remove pkglibtorrent-rasterbar


#4

Package `pkglibtorrent-rasterbar’ is not currently installed.

xbps-install -Su

boost-1.64.0_2 (update) breaks installed pkg `libtorrent-rasterbar-1.0-1.0.10_2’
Transaction aborted due to unresolved dependencies.


#5

what about sudo xbps-remove libtorrent-rasterbar ?


#6

#7

xbps-remove libtorrent-rasterbar
Package `libtorrent-rasterbar’ is not currently installed.

also funny xbps stuff:

sudo xbps-remove texlive2016-bin-2016_1
texlive2016-bin-2016_1 (remove) breaks installed pkg `texlive-bin-2016_1’


#8

uhh, it seems, that -R flag just fixed all of this…

sudo xbps-remove -R libtorrent-rasterbar-1.0-1.0.10_2

now xbps lets me update my system and the ‘boost’ package doesn’t interfere