Home | News | Download | Packages | Forum | Wiki | Github

[SOLVED] Unable to change wallpaper


So, I’ve just installed (actually, second install, you will see bellow) void linux.
I’m running void-live-x86_64-musl-enlightenment on a HP elitebook with a i5 CPU, 8Gb of RAM and no hard drive. The system is actually installed on 16Gb 3.1 USB and I’ve customized the boot in the UEFI to point at the void EFI file on my /boot/efi partition, so it boots directly as if the USB was the internal hard drive.

One observation on the installation. In the first install I did I created a user account during set-up and after installation I could not access WIFI when logged as user, but everything worked fine under root. That was a glibc enlightenment.
I decided to wipe the USB clean and did a second install without user account and decided to test musl. I updated the system, did some configuration and then created a user account, now WIFI works under user as well. Great! Don’t know if you were aware of this or not?

Now to my question. For some reason I’m unable to change the default background in my user profile. If I go to themes or wallpaper every time I select a picture from my picture folder the application just closes without changing the background. From the CLI, I can see a .edj file as been created in /.e/e/backgrounds, but when I try to use it the screen flashes and gets back to default.
Not a big deal, since I quite like the default dark theme, but it would be good to know why?!
Also if I download, say emerald themes, they are there, but I can not change the default.


Just checked that if I login as root I can change the wallpaper, but not if I’m logged as user! Can I add some permission to my user profile to change that?


That’s with connman, correct?

I had to use this solution on a glibc install - Connman needs root


That’s correct!
But my problem right know is with the locked background under user.


Ok! Problem solved.
[pedro@pin ~]$ chmod 777 -R .e/e/backgrounds

So now I can change the wallpaper