Home | News | Download | Packages | Forum | Wiki | Github

[SOLVED]Todays updates broke named (bind)


#1

Hi

Just discovered that after updating my system tonight named stopped working. ps shows process as defunct and sv says something like “got term” i think. Late for me now and I have to work in the morning but if anyone else has this and finds a solution please post here.

Thanks


#2

Hello!

Same with my 32bit system, with today’s kernel update: wish, firefox-esr, qupzilla failing; jwm, octoxbps, gvim, libreoffice running normally. Tried to downgrade glibc to 2.24_4, but it’s not in the repo. 64bit system with yesterday’s updates apparently ok (need to recheck today).

Thanks for your help!


#3

xdowngrade /var/cache/xbps/glibc-2.24_4.i686.xbps, would be good if we could find out if its the kernel or the glibc update.
I don’t have a i686 system to test.


#4

Hi

I just tried xdowngrade glibc on my x86-64 laptop, which I had installed bind on to investigate the problem on my main box, and now sv can start it OK. Glibc problem by the look of it. For info, it would run in a root terminal with -f -g options but not with just -f.


#5

Duncaen, thank you for your help, but unfortunately I did clean the local cache, so I don’t have that file anymore… Is there a way to get it again?

Thanks!


(Masato the Empty) #6

I’ve sent you a link for the i686 version of 2.24_4.

Just to make sure nothing is wrong with the file (or nefarious) here’s the checksum I have for the file (sha256): 3cbd86c1d94c6855567324bb3cfecd4d5837638bfbc46b2675591c55a53156c2

If anybody else wants that, PM me for the link. They auto-expire in a couple of days though, so I don’t want to post it to the forum (dead links suck).

But hopefully, this gets resolved soon anyway.


#7

Got the feeling I am the only one using bind :-/ Got it to work though. Added -g for logging to stderr to the /etc/sv/named/run file and it starts OK. Don’t see any logging anywhere but not too bothered as long as it’s working.


#8

duncaen fixed this with a patch to bind now. Thanks duncaen. Added a seccomp filter rule for getpid() I think.


#9

Heads up! If you mention someone you can put an @ like @Duncaen so he will get notified!

This can be closed then I guess?


#10

Is there a new update to 32-bits glibc planned?


#11

No, no idea what the issue is.
And it doesn’t help that this is mixed with other issues, this thread is not related to it.
I tried to reproduce it in a i686 vm but couldn’t.


#12

Hi

Could you send me a link to the i686 version of glibc 2.24 aswell?

There seems to be a bug in the latest version and I also don’t have it cached.

Thanks


(Masato the Empty) #13

I don’t have the i686 version at present; the 32-bit VM I had it on has since been reinstalled a few times (I don’t have a production system in i686 flavor, only test systems). Links are dead as well (I used transfer.sh). So I only have the 64-bit one in my cache…

At this point in time, it’s possible that the fixes will have to occur not in glibc, but in software linking to it. For instance, named needed patching according to @gazza; other software might as well. What bugs are you seeing in what packages? If they are a bit older and haven’t been built since the move to glibc2.25 (feb 6/7), then maybe that’s the first thing to try (next would be checking upstream for patches that could be backported to the last release version of your software).

Perhaps @void_but_not_null can forward the favor and upload it somewhere like transfer.sh?

Or if anyone else cares to help out?


#14

Oh that is too bad.

I have seemingly random crashes in multiple applications all relating to the memchr_sse2 function in glibc
I think I am affected by this issue https://sourceware.org/bugzilla/show_bug.cgi?id=21182


(Masato the Empty) #15

Interesting link.

Since there’s a vod maintainer involved, I think that once a patch is agreed upon upstream, we’ll see it ported here. (it looks like they’re banging it out as we type so with any luck it won’t be too long - I know, even a day is an eternity when everything is crashing on you :disappointed:)


#16

Here’s the new link in transfer.sh (hope this package won’t be needed much longer):

https://transfer.sh/K1wab/glibc-2.24-4.i686.xbps

sha256sum=3cbd86c1d94c6855567324bb3cfecd4d5837638bfbc46b2675591c55a53156c2

Regards,


#17

Please rename it to glibc-2.24_4.i686.xbps …

Regards,


#18

Thanks a lot! You saved my day

In the future I will be more careful with clearing my cache