Home | News | Download | Packages | Forum | Wiki | Github

SOLVED: Stuck building gocryptfs


#1

I am trying to build http://github.com/rfjakob/gocryptfs but I am stuck where there is no file libcrypto.pc to be found on Void… Any suggestions?


#2

libcrypto.pc is in libressl-devel. :slight_smile:

You can search for files with xlocate from the xtools package:

xlocate libcrypto.pc


#3

If I do xpbs-install -S libressl-dev it comes back with an error. Rebooting makes it stuck flashing bootmessages on and off… On either kernel version… OK, it is not able to start the desktop environment somehow, this has never happened before. It keeps switching to tty7 which makes working on things hard. Nothing in .xsession-errors


#4

But it’s libressl-devel not -dev.


#5

Sorry, I can’t follow: what is stuck flashing? Your machine after a failed xbps-install?


#6

I’m trying xpbs-install -S libressl-devel but it comes back the same:
xbps-install: error while loading shared libraries: libcrypto.so.41: cannot open shared object file: No such file or directory. Same when I try anything xbps-*…


#7

Sounds strange. First I would check the filesystem and the harddrive’s smart data.


#8

Does this mean my Void installation is now completely hosed, or is there still a way to salvage it?

What went wrong was I removed libcrypto41 (because I had added it with xbps-install -S) with xbps-remove -fFR… I’m guessing it was already installed and I should never have removed it.


#9

My bad I fear… See post below.


#10

I think you should be able to reinstall libcrypto41 with a live cd (see option -r of xbps-install) or a static xbps version from here.


#11

Hmmm can’t even wget or ping… Let alone xbps-anything. Looks like I’m done for. Unless there is a more manual way. I got the static file, but can’t use it. That was almost 1 year of Void stability (and no systemd)…!

I am now wondering if I missed a warning when I uninstalled libcrypto41… That was the undoing I’m sure, PEBKAC.


#12

What you could try is to get the corresponding libcrypto41-*.xbps (via a live cd or a different system), manually extract it somewhere (tar -xJf ...) and copy the library to /usr/lib and then force install libcrypto41.

The x86_64 glibc version would be
https://repo.voidlinux.eu/current/libcrypto41-2.5.5_1.x86_64.xbps


#13

Copied the library files manually. Looks like back to normal. I think I want to properly install & register libcrypto in xbps – that worked…!

Installing libressl-devel done.

And gocryptfs built!!

Thank you very much for your help!


#14

For future don’t use -F, xbps-remove will never perform an operation that would break your system, unless this flag is specified.

From the xbps-remove man page:

-F, --force-revdeps
         Forcefully remove package even if there are reverse dependencies
         and/or broken shared libraries (DANGEROUS!).

#15

Thanks for this warning, I will change my ways.
It does explain the breakage that resulted…