Home | News | Download | Packages | Forum | Wiki | Github

[Solved] Steam controller not working correctly


#1

ok guys, I have a follow up.

Steam seems to no longer be crashing, but im having a different issue with my steam controller. Steam detects it just fine, and I can navigate big picture mode just fine. No games seem to detect it though? There is a entry for /usr/lib/udev/rules.d/99-steam-controller-perms.rules and as far as I can tell its configured correctly:

> #USB devices
> SUBSYSTEM=="usb", ATTRS{idVendor}=="28de", MODE="0666"
> # Oculus HID Sensor naming and permissioning
> KERNEL=="hidraw*", SUBSYSTEM=="hidraw", ATTRS{idVendor}=="2833", MODE="0666"

So that doesnt seem to be the issue, anyone have any thoughts?


Steam crashes to desktop
#2

Hello All,

I figured this out. In case anyone else was having this issue, here is the solution.

/usr/lib/udev/rules.d/99-steam-controller-perms.rules is set up correctly for the steam controller to work in steam, but does not contain an aurgument that is needed for it to emulate an xinput gamepad. I added this to the end of that config file and rebooted,

# This rule is necessary for gamepad emulation; make sure you replace 'pgriffais' with a group that the user that runs Steam belongs to KERNEL=="uinput", MODE="0660", GROUP="users", OPTIONS+="static_node=uinput"

now everything seems to work just fine. I changed the example group “pgriffais” to “users” which seemed logical.

I found this info on the steam forums http://steamcommunity.com/app/353370/discussions/0/490123197956024380/


(Juan RP) #3

Thanks for your info, I’ll apply the changes to the steam package soon.

Cheers


(markackerman8@gmail.com) #4

A recurring issue with my steam controller pairing (wireless) after trying all the similar solutions to the main comment here was to …
… SOLVED …

simply opt out of "Beta Mode " Participation, or into it if not in it yet.

Either seems to fix whatever issue popped up.