Home | News | Download | Packages | Forum | Wiki | Github

[SOLVED] Segmentation fault on many apps


I installed Void Linux yesterday. I was looking for a distribution with fresh packages, free of systemd. Unfortunately, there is less and less distributions free from systemd.

This distribution will not be as easy as debian, but you have to expand your horizons, right?

I have installed several applications, but some of them return Segmentation fault at startup. I counted 3. I am a bit worried that something is wrong with the system, because these applications have never caused me trouble with other distributions.

  1. qbittorrent
  2. rofi
  3. keepassxc
  4. octoxbps (this is new for me)

My rig:
CPU: Intel i5 6500
Mainboard: MSI Z170-A PRO
GPU: AMD HD 7850

What other information could I give you? (please enter commands, I’m an intermediate linux user)

Thanks in advance

(Erin) #2

Have you updated the system xbps-install -Su plus keep rerunning until it wants to update no more and rebooted after the last? All but No.2 are Qt based; there are plenty of comments about Qt stability on the forum.


Thank you for a blazing fast answer. :grinning:
After yesterday’s huge update, I did not think there would be something to update. I feel stupid not having tried it before :flushed:

It helped. All applications work, even Rofi, despite independence from Qt.

How often does Void update the Qt libraries, that it causes such chaos?

(Erin) #4

Software is software and sometimes an update brings unwarranted/unwanted features. In some distros, these are hidden but rolling release distros sometimes suffer from non-desired features. The Void devs are very active and frequently overcome these rapidly. Qt seems to suffer more than most; it is one of the reasons I am living in a Qt free world! Potentially, your issue may have been non-Qt related but it is wonderful that it is fixed for you. Enjoy your Void journey.


better to avoid octoxbps :octopus:


Thanks for the warning, but it’s a pity you did not explain the reasons behind it.

Thanks anyway.

Edit: Either I am so tired or the browser render the link as if it were not a link.


@JackStarborn by clicking the above link. :roll_eyes: