Home | News | Download | Packages | Forum | Wiki | Github

[Solved] Running a QT5 application shows "coudl not load the Qt platform plugin "xcb""


(Ibn Saeed) #1

I have installed a tar package manually. followed the instructions in the readme

Here are the insstructions for installation

load the Qt platform plugin "xcb"
2 1) LINUX
3
4 First install the following dependencies:
5
6 -Python 3.5 or later (http://www.python.org)
7 -PyQt 5.6 or later
8 (http://www.riverbankcomputing.co.uk/software/pyqt/download, which boils
9 down to ‘sudo pip3 install PyQt5’).
10 -If you want to be able to enter formulas using latex syntax, make sure
11 that latex and dvipng are installed.
12 -Matplotlib (http://matplotlib.sourceforge.net/)
13 -EasyInstall (http://peak.telecommunity.com/DevCenter/EasyInstall)
14 -cheroot 5 or later (https://pypi.python.org/pypi/Cheroot/,•
15 pip3 install cheroot)
16 -Webob 1.4 or later (http://webob.org)
17 -PIL (https://python-pillow.org, pip3 install pillow)
18
19 To actually install mnemosyne:
20 -Extraxt the .tar.gz file and change to its root directory (i.e.
21 probably the directory where you found this README file).
22 -Type ‘python3 setup.py install’ as root.

when i run the applicatoin it shows

This application failed to start because it could not find or load the Qt platform plugin “xcb”


(Salil Wadnerkar) #2

You don’t have to install PyQt5 from the source. These packages are available from the void repo. You can uninstall PyQt5 and the packages you installed using pip3, and then run

sudo xbps-install -S python3-PyQt5 python3-PyQt5-dbus

(Jacob Moen) #3

Alternatively, check the package recipes to see if you ought to install a dependency or two. :slight_smile:


(Ibn Saeed) #4

solved.

removed PyQt5 from pip3 and reinstalled it again with pip3.