Home | News | Download | Packages | Forum | Wiki | Github

[SOLVED] Problem (?) with xauth


After one week away, I updated my system yesterday when I came back home.
Everything is working properly on my laptop but, at login I get

xauth: (stdin):1: bad display name "my_host_name:0" in "add" command

and at logout I get

xauth (argv):1: bad display name "my_host_name:0" in "remove" command

I’ve never seen this prior to yesterday and wonder why these messages are showing-up now? As mentioned, everything is working, login takes a fraction of a second longer but, after that everything works as expected.
I’ve searched the web for these messages but, could only find these in connection to remote logins via ssh, something that I’m not using.

My set-up: Void musl, awesome wm, no display manager, login from console, using the following .bash_profile,

if [[ -z $DISPLAY ]] && [[ $(tty) = /dev/tty1 ]]; then
exec startx

and this line on .xinitrc

exec ck-launch-session dbus-launch --sh-syntax --exit-with-session awesome

Any ideas?


If not using a display manager nor a desktop environment, do you need consolekit to start the xserver session for any other specific reason?

xauth shouldn’t be contacting the server unless something is calling it. ie, consolekit or a display manager.


I’ve always had Consolekit2 installed without seeing these lines. There might be other ways of doing this but, Consolekit2 is there to allow auto mounting usb devices and my android phone when needed. It is also there, to give access to :neutral_face: pulseaudio which I need, since bluez doesn’t work without it. Well, at least not without this https://github.com/Arkq/bluez-alsa


I’m seeing same xauth messages, adding my_hostname to /etc/hosts - fixes the issue.
Now figuring out why X is launching on tty1, enyone else?



At least, I’m not the only one… never had to modify /etc/hosts before!? Sorry for my dumb question but, where did you add it? This is what I have

# /etc/hosts: static lookup table for host names

#<ip-address>		<hostname.domain.org>	<hostname>
xxx.x.x.x		localhost.localdomain	localhost
::1			localhost.localdomain	localhost ip6-localhost

# End of file

And, yes X is also launching on tty1 here?!

EDIT: I’ve removed/re-installed xorg, xorg-apps and xauth but, nothing changes…


It was the same with me, and I was able to solve it.

See, void is my hostname:

# /etc/hosts: static lookup table for host names

#<ip-address>		<hostname.domain.org>	 <hostname>
xxx.x.x.x	        localhost.localdomain	 void
::1		        localhost.localdomain	 void ip6-localhost

# End of file

As for X launching in tty1, adding this in my mkshrc solved:
alias startx="startx -- vt7"


yeah, I had the same problem yesterday… :roll_eyes:

…was fixed by this commit ! :sweat_smile:


I was just wondering what had caused this behavior change when I saw your post :upside_down_face:
System updated and no more xauth messages :rofl: