Home | News | Download | Packages | Forum | Wiki | Github

[solved/patched] Fontconfig update breaks my urxvt & polybar


#1

This morning I ran a full system update which includes an update of the fontsconfig pkg. This broke my urxvt and polybar from starting… Had to downgrade the package and everything worked again.

Is someone have a similiar issue and knows how to fix it?


(Erin) #2

Have a read of issues on GitHub, raise a specific one for your issue. Alternative “fix it” - don’t upgrade :rofl:


(D) #3

After Update fontconfig, i can’t use mouse in sublime anymore. Downgrade fontconfig and everything worked again.


#4

You are right. Maybe I have to recompile these packages against the updated fontconfig-devel pkg?


(ruelleducube@gmail.com) #5

I’m trying to downgrade my fontconfig package with the command sudo xbps-install -Sf fontconfig-2.12.6_1 but it’s not able to locate the package. It must be my fault, can you give me the exact command to downgrade please.


#6

Install xtools. Navigate to /var/cache/xbps and run xdowngrade and the *.xbps version you want to downgrade to.

Have alsp a look at:


(ruelleducube@gmail.com) #7

Thank you so much, it’s working again with a downgrade to fontconfig-2.12.6_1 !


#8

You are welcome :slight_smile:


#9

I had the same problem after fontconfig update.

I changed the fonts name in urxvt and bar config file. First I had the font name for examle xxxxxx. After fontconfig update I change it to xxxxxx-font. After next fontconfig update I changed it to xxxxxx again. After todays update I had do nothing, but for example youtube-viewer doesn’t use my font. But I don’t care.


#10

Thx. Can you post your current .Xresources line for the font config?


#11

Here You are, but it is .Xdefaults in my case:

!! Appearance
urxvt.termName: rxvt-unicode
urxvt.scrollBar: false
urxvt.background: [70]#000000
!urxvt.background: black
urxvt.foreground: grey
!urxvt.foreground: #D75F00
urxvt.depth: 32
!!! Font prefferenes
urxvt.font: xft:ohsnap:pixelsize=18
urxvt.boldFont: xft:ohsnap:pixelsize=16:weight=bold
urxvt.letterSpace: -1
!!! Larger history limit
!urxvt.saveLines: 1000000
!
!!! Perl extensions
urxvt.perl-ext-common: default,matcher,font-size
!!! Open urls in browser with Control-Click
!urxvt.urlLauncher: /usr/bin/firefox
urxvt.urlLauncher: firefox
urxvt.colorUL: #4682B4
urxvt.matcher.button: C1
!!! Change font size on Control-Plus/Minus
URxvt.keysym.Control-0x2b: perl:font-size:increase
URxvt.keysym.Control-0x2d: perl:font-size:decrease
!
!!! Yeah, I am one of those, who use these keys in Vim :frowning:
urxvt.keysym.Home: \033[1~
urxvt.keysym.End: \033[4~
urxvt.keysym.Control-Up: \033[1;5A
urxvt.keysym.Control-Down: \033[1;5B
urxvt.keysym.Control-Left: \033[1;5D
urxvt.keysym.Control-Right: \033[1;5C
!
!!! Tango color theme
!!! Strange - it matches tango from gnome-terminal, but looks different
URxvt.color0: rgb:00/00/00
URxvt.color1: rgb:CC/00/00
URxvt.color2: rgb:4E/9A/06
URxvt.color3: rgb:C4/A0/00
URxvt.color4: rgb:34/65/A4
URxvt.color5: rgb:75/50/7B
URxvt.color6: rgb:06/98/9A
URxvt.color7: rgb:D3/D7/CF
URxvt.color8: rgb:55/57/53
URxvt.color9: rgb:EF/29/29
URxvt.color10: rgb:8A/E2/34
URxvt.color11: rgb:FC/E9/4F
URxvt.color12: rgb:72/9F/CF
URxvt.color13: rgb:AD/7F/A8
URxvt.color14: rgb:34/E2/E2
URxvt.color15: rgb:EE/EE/EC
URxvt.colorBD: rgb:ff/ff/ff

EDIT:

BTW How to paste long text in this special window with scrollbar??? Really I don’t know :thinking:


#12

Thank you

My definition looks similiar. Don’t understand why it works for you and does not my case… :confused:


#13

What is your font? Try to change .Xresources name to .Xdefaults


#14

URxvt*font: xft:Source Code Pro:style=Medium:weight=normal:pixelsize=16:antialias=true:hinting=true


#15

Whats the difference between those?


#16

In the past urxvt read .Xdefaults file.


#17

Ok. Will give it a try but don’t think this is the problem… It worked without problems until todays fontconfig update…


#18

Here’s the difference, https://superuser.com/questions/243914/xresources-or-xdefaults

Both are empty files in my system, though… awesome has it’s own configuration files, as does sakura. So, I have no need for those and no issues with fonts :wink:


#19

Thanks for pointing this out @pin


#20

Looks like this is a official bug of fontconfig 2.13 which is fixed in git version:
https://bugs.freedesktop.org/show_bug.cgi?id=105415

Hopefully a new patched version release will follow soon.

UPDATE:
Just built it with the following patch applied: https://bugs.freedesktop.org/attachment.cgi?id=137958

Seems to fix the issue. :slight_smile: