Home | News | Download | Packages | Forum | Wiki | Github

[SOLVED] (ok I give up) startx per everything I've read in here and still no go


(Userx) #1

I have been tinkering with this create a USB full install onto a USB Stick got it all the way up to startx and still cannot get a Window Manager / xorg / XWindows to start

every step from step one:

create partitions on USB Stick, flag boot partition
/dev/sdc1 /
/dev/sdc2 swap

mkdir /void
mount /dev/sdc1 /void

sudo xbps-install -S -R http://repo3.voidlinux.eu/current -r /void base-system nano grub wireless_tools xorg-fonts xf86-input-synaptics network-manager-applet xtrans inetutils dhclient NetworkManager xorg-minimal network-manager-applet xtrans ipw2100-firmware ipw2200-firmware inetutils acpid NetworkManager xf86-input-evdev xf86-video-ati xorg-input-drivers xf86-video-vesa xinit fluxbox ConsoleKit2 lxdm xorg-server xauth cgmanager dbus xfce4

i

; to copy and paste into terminal to run one after the other

sudo mount --rbind /dev /void/dev ;

sudo mount --rbind /dev /void/dev ;

sudo mount --rbind /proc /void/proc ;

sudo mount --rbind /sys /void/sys ;

sudo chroot /void ;

bash

bash-4.3# passwd root

New password:
Retype new password:
passwd: password updated successfully

chown root:root / ;

chmod 755 / ;

nano /etc/rc.conf

echo USBVoidLinux > /etc/hostname ;

nano /etc/fstab

grub-install /dev/sdc

nano /etc/locale.conf

nano /etc/default/libc-locales

xbps-reconfigure -f glibc-locales

echo hostonly=yes > /etc/dracut.conf.d/hostonly.conf

nano /etc/default/grub

uname -r

xbps-reconfigure -f linux4.8

^D
rebooted

get into the USB Stick Install
run commands to get internet…

startx

it starts
black screen moments later it shuts down without error

#!/bin/sh

~/.xinitrc

Executed by startx (run your window manager from here)

if [ -d /etc/X11/xinit/xinitrc.d ]; then
for f in /etc/X11/xinit/xinitrc.d/*; do
[ -x “$f” ] && . "$f"
done
unset f
fi

exec gnome-session

exec startkde

exec ck-list-sessions startxfce4

…or the Window Manager of your choice

#exec fluxbox

from this page to set a session

dbus/cgmanager/consolekit soft linked and services started

exec ck-list-sessions

Session1:
unix-user = '1000’
realname = '(null)'
seat = 'Seat1’
session-type = ''
active = FALSE
x11-display = ''
x11-display-device = ''
display-device = '/dev/tty1’
remote-host-name = ''
is-local = TRUE
on-since = '2016-11-28T21:35:24.549767Z’
login-session-id = '1’
XDG_RUNTIME_DIR = ‘/run/user/1000’

echo “setxkbmap us” > /etc/X11/xinit/xinitrc.d/20-keymap

chmod 0755 /etc/X11/xinit/xinitrc.d/20-keymap

xWindows has a message in there about it has no idea what setxkbmap is.

startx

black screen xWindows shuts down again, and again, and again …


Blackscreen on Xorg start
#2

Please format all of the commands and files in your posts as code. Things will then look like a bit like this:

#!/bin/sh
#Executed by startx (run your window manager from here)

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  done
  unset f
fi
exec gnome-session
exec startkde
exec ck-list-sessions  startxfce4
#...or the Window Manager of your choice
exec fluxbox

This makes it much easier for us to read what you are trying to show us. You can just select some text and press the ‘preformatted text’ button (it looks like this: </>) and it will do the work for you.

When startx fails it writes a log of what’s happened. It will tell you where this is stored after it quits – have a look at it. Make sure to scroll to the very end, as it may have previous failures listed.

I suspect that you have not installed gnome, so the ‘gnome-session’ command does not exist. The word ‘exec’ in your script makes it so that if gnome-session fails or closes then the entire script is immediately aborted (ie none of the lines after ‘exec gnome-session’ are ever run).

Don’t worry about consolekit or any of that stuff. Create a file called “.xinitrc” in your home folder (don’t forget the dot) and put only one line into it:

fluxbox

That’s it. You can write ‘exec fluxbox’ if you want, but it’s not really necessary. Oh and make sure to install fluxbox if you have not already.

Consider adding more complexity only if you find you need/want it and only after you have a working graphical environment. For example this is my .xinitrc file after many years of adding tweaks:

source ~/.vars

if [ -z $throughVNC ]
then
	#setxkbmap -option terminate:ctrl_alt_bksp

	# Extra modes for the second monitor
	xrandr --newmode "1440x900_60"  106.47  1440 1520 1672 1904  900 901 904 932  -HSync +Vsync
	xrandr --newmode "1440x900_77"  140.28  1440 1536 1688 1936  900 901 904 941  -HSync +Vsync
	xrandr --addmode DVI-1 1440x900_60
	xrandr --addmode DVI-1 1440x900_77

	fixres
	redshift -l 34:151 -t 6500:4000 &
	~/.fehbg &
else
	xsetroot -solid black
fi

# Font paths
#xset +fp /usr/share/fonts/local  #terminus
#xset +fp /home/valentine/.fonts 
#xset fp rehash 

xset r rate 180 40  
xrdb -merge ~/.Xresources 

exec i3

This will of course not work on your system, as you don’t have some of the files that I have, let alone the same problems/desires.


(Userx) #3

I never tried that one, I’ve always used the " double quotes. for the most part. too many “blogs” forums got so many different ways to formate everything it gets confusing. I get tired of experimenting.

as far as the .xinitrc file yep it is in that blob of stuff I posted.

lets see if that formatting thing [ </> ] works for me

!/bin/sh

~/.xinitrc

Executed by startx (run your window manager from here)
if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  done
  unset f
fi
exec gnome-session
exec startkde
exec ck-list-sessions  startxfce4
...or the Window Manager of your choice
exec fluxbox

I have fluxbox installed but it didn’t work so I installed xfce4

that </> and double quotes do not show that pound sign for commenting out statements. I think it is used to indicate a header size because it makes the fonts huge when it is at the start of the line it is commenting out.

I’ve never had to do anything fancy or as adding more complexity to that file before and getting startx to work within in other Distros before. there is no Xsession_error file in home. as far as adding all of that fancy stuff that is a worry about that later thing. I just want to get GUI working before all of that. btw.

MOD:
Ok just booted back into it and deleted the old /var/log/Xorg.0.log, then ran startx

/var/log/Xorg.0.log is huge
let me look through it first…
I do not see anything saying error. it searches video types then loads, searches keyboard stuff then loads then closes everything and shuts down in a normal state without error.

I could post the entire log in here or give it a bogus extension to get it to upload … so you or someone could down load it then remove the extension then read it as a flat file.

this maybe the only thing I can think of that is prevetning it

   142.081] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Nov 28 20:07:03 2016
[   142.082] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   142.083] (==) No Layout section.  Using the first Screen section.
[   142.083] (==) No screen section available. Using defaults.
[   142.083] (**) |-->Screen "Default Screen Section" (0)
[   142.083] (**) |   |-->Monitor "<default monitor>"
[   142.083] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.

But it states that it is using the Default configuration.
using my running void install on my laptop this is what is in where the line that states this

[ 142.082] (==) Using system config directory “/usr/share/X11/xorg.conf.d”

userx@voided1.what/etc/X11/xinit>> ls /usr/share/X11/xorg.conf.d
10-amdgpu.conf  10-quirks.conf   70-synaptics.conf
10-evdev.conf   50-vmmouse.conf  70-wacom.conf

there isn’t even what I see to be anything for a monitor / screen

Xorg uses a configuration file called xorg.conf for its initial setup

this setup on VOID in my laptop does not even have a xorg.conf file I used find and did not find it.

userx@voided1.what/etc/X11/xinit>> sudo find / -name xorg.conf
find: ‘/run/user/1000/gvfs’: Permission denied
userx@voided1.what/etc/X11/xinit>>

this is my .xinitrc from my Debian install on my laptop all I have is
#!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  done
  unset f
fi

xset -dpms s off &

# exec gnome-session
# exec startkde
# exec startxfce4
# ...or the Window Manager of your choice
exec openbox-session

nothing fancy and startx works No Problems.


#4

Xorg should autodetect everything necessary. You don’t need an /etc/xorg.conf or similar unless you specifically have something that needs fixing.

nothing fancy and startx works No Problems.

Good :slight_smile:

N.B. I don’t have a /etc/X11/xinit/xinitrc.d/ folder in my Void install. If you don’t then those top few lines are not doing anything.

that and double quotes do not show that pound sign for commenting out
statements. I think it is used to indicate a header size because it
makes the fonts huge when it is at the start of the line it is
commenting out.

The quoting feature is designed to quote other people’s posts, so it thinks #'s are formatting marks. The code quoting feature is designed to ignore formatting marks.

/var/log/Xorg.0.log is huge
let me look through it first…

Indeed, it’ll have a log of every attempt you’ve made to startx. If you peruse it using the ‘less’ command then you can immediately scroll to the bottom by pressing Shift+g


(Userx) #5

I use more and page though it, but anyways, that first statement on nothing fancy and startx still works is for other Linux OS’s not Void.

the huge log is from just one try as I deleted it first to get rid of everything so I’d only have one attempt logged into that file.

the bottom line in it states this.

[   143.530] (II) Server terminated successfully (0). Closing log file.

searching then loading video here

[   142.083] (II) Loader magic: 0x562a19fadc40
[   142.083] (II) Module ABI versions:
[   142.083]     X.Org ANSI C Emulation: 0.4
[   142.083]     X.Org Video Driver: 20.0
[   142.083]     X.Org XInput driver : 22.1
[   142.083]     X.Org Server Extension : 9.0
[   142.083] (II) xfree86: Adding drm device (/dev/dri/card0)
[   142.087] (--) PCI:*(0:1:0:0) 1002:6760:103c:161e rev 0, Mem @ 0xc0000000/268435456, 0xd4400000/131072, I/O @ 0x00004000/256, BIOS @ 0x????????/131072
[   142.087] (II) LoadModule: "glx"
[   142.087] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   142.090] (II) Module glx: vendor="X.Org Foundation"
[   142.090]     compiled for 1.18.4, module version = 1.0.0
[   142.090]     ABI class: X.Org Server Extension, version 9.0
[   142.090] (==) AIGLX enabled
[   142.090] (==) Matched fglrx as autoconfigured driver 0
[   142.090] (==) Matched ati as autoconfigured driver 1
[   142.090] (==) Matched fglrx as autoconfigured driver 2
[   142.090] (==) Matched ati as autoconfigured driver 3
[   142.090] (==) Matched modesetting as autoconfigured driver 4
[   142.090] (==) Matched fbdev as autoconfigured driver 5
[   142.090] (==) Matched vesa as autoconfigured driver 6
[   142.090] (==) Assigned the driver to the xf86ConfigLayout
[   142.090] (II) LoadModule: "fglrx"
[   142.090] (WW) Warning, couldn't open module fglrx
[   142.090] (II) UnloadModule: "fglrx"
[   142.090] (II) Unloading fglrx
**[   142.090] (EE) Failed to load module "fglrx" (module does not exist, 0)**
[   142.090] (II) LoadModule: "ati"
[   142.090] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
[   142.090] (II) Module ati: vendor="X.Org Foundation"
[   142.090]     compiled for 1.18.4, module version = 7.8.0
[   142.090]     Module class: X.Org Video Driver
[   142.090]     ABI class: X.Org Video Driver, version 20.0
[   142.090] (II) LoadModule: "radeon"
[   142.090] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
[   142.090] (II) Module radeon: vendor="X.Org Foundation"
[   142.091]     compiled for 1.18.4, module version = 7.8.0
[   142.091]     Module class: X.Org Video Driver
[   142.091]     ABI class: X.Org Video Driver, version 20.0
[   142.091] (II) LoadModule: "modesetting"
[   142.091] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[   142.091] (II) Module modesetting: vendor="X.Org Foundation"
[   142.091]     compiled for 1.18.4, module version = 1.18.4
[   142.091]     Module class: X.Org Video Driver
[   142.091]     ABI class: X.Org Video Driver, version 20.0
[   142.091] (II) LoadModule: "fbdev"
**[   142.091] (WW) Warning, couldn't open module fbdev** <--- there is something 
[   142.091] (II) UnloadModule: "fbdev"
[   142.091] (II) Unloading fbdev
**[   142.091] (EE) Failed to load module "fbdev" (module does not exist, 0)** <--- there is something
[   142.091] (II) LoadModule: "vesa"
[   142.091] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[   142.091] (II) Module vesa: vendor="X.Org Foundation"
[   142.091]     compiled for 1.18.0, module version = 2.3.4
[   142.091]     Module class: X.Org Video Driver
[   142.091]     ABI class: X.Org Video Driver, version 20.0
[   142.091] (II) RADEON: Driver for ATI/AMD Radeon chipsets: 

After it showing going through just about every ATI Radeon chip set it then logs this,

[   142.093] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[   142.093] (II) VESA: driver for VESA chipsets: vesa
**[   142.093] (--) using VT number 7** <--- there is something

[   142.099] (II) [KMS] Kernel modesetting enabled.
[   142.099] (WW) Falling back to old probe method for modesetting <--- there is something
[   142.101] (WW) Falling back to old probe method for vesa <--- there is something
[   142.101] (II) RADEON(0): Creating default Display subsection in Screen section
    "Default Screen Section" for depth/fbbpp 24/32
[   142.101] (==) RADEON(0): Depth 24, (--) framebuffer bpp 32
[   142.101] (II) RADEON(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[   142.101] (==) RADEON(0): Default visual is TrueColor
[   142.101] (==) RADEON(0): RGB weight 888
[   142.101] (II) RADEON(0): Using 8 bits per RGB (8 bit DAC)
[   142.101] (--) RADEON(0): Chipset: "CAICOS" (ChipID = 0x6760)
[   142.103] (II) Loading sub module "fb"
[   142.103] (II) LoadModule: "fb"
[   142.104] (II) Loading /usr/lib/xorg/modules/libfb.so
[   142.104] (II) Module fb: vendor="X.Org Foundation"
[   142.104]     compiled for 1.18.4, module version = 1.0.0
[   142.104]     ABI class: X.Org ANSI C Emulation, version 0.4
[   142.104] (II) Loading sub module "dri2"
[   142.104] (II) LoadModule: "dri2"
[   142.104] (II) Module "dri2" already built-in
[   142.104] (II) Loading sub module "exa"
[   142.104] (II) LoadModule: "exa"
[   142.104] (II) Loading /usr/lib/xorg/modules/libexa.so
[   142.105] (II) Module exa: vendor="X.Org Foundation"
[   142.105]     compiled for 1.18.4, module version = 2.6.0
[   142.105]     ABI class: X.Org Video Driver, version 20.0
[   142.105] (II) RADEON(0): KMS Color Tiling: enabled
[   142.105] (II) RADEON(0): KMS Color Tiling 2D: enabled
[   142.105] (II) RADEON(0): KMS Pageflipping: enabled
[   142.105] (II) RADEON(0): SwapBuffers wait for vsync: enabled
[   142.105] (II) RADEON(0): Output LVDS has no monitor section
[   142.251] (II) RADEON(0): Output DisplayPort-0 has no monitor section
[   142.396] (II) RADEON(0): Output DisplayPort-1 has no monitor section
[   142.542] (II) RADEON(0): Output DisplayPort-2 has no monitor section
[   142.551] (II) RADEON(0): Output VGA-0 has no monitor section
[   142.551] (II) RADEON(0): EDID for output LVDS
[   142.551] (II) RADEON(0): Manufacturer: SEC  Model: 324c  Serial#: 0
[   142.551] (II) RADEON(0): Year: 2010  Week: 0
[   142.551] (II) RADEON(0): EDID Version: 1.3
[   142.551] (II) RADEON(0): Digital Display Input
[   142.551] (II) RADEON(0): Max Image Size [cm]: horiz.: 31  vert.: 17
[   142.551] (II) RADEON(0): Gamma: 2.20
[   142.551] (II) RADEON(0): DPMS capabilities: StandBy Suspend Off
[   142.551] (II) RADEON(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4 
[   142.551] (II) RADEON(0): First detailed timing is preferred mode
[   142.551] (II) RADEON(0): redX: 0.566 redY: 0.337   greenX: 0.351 greenY: 0.560
[   142.551] (II) RADEON(0): blueX: 0.150 blueY: 0.094   whiteX: 0.313 whiteY: 0.329
[   142.551] (II) RADEON(0): Manufacturer's mask: 0
[   142.551] (II) RADEON(0): Supported detailed timing:
[   142.551] (II) RADEON(0): clock: 98.2 MHz   Image Size:  310 x 174 mm
[   142.551] (II) RADEON(0): h_active: 1600  h_sync: 1648  h_sync_end 1680 h_blank_end 1760 h_border: 0
[   142.552] (II) RADEON(0): v_active: 900  v_sync: 902  v_sync_end 907 v_blanking: 930 v_border: 0
[   142.552] (II) RADEON(0): Unknown vendor-specific block f

[ 143.530] (II) Server terminated successfully (0). Closing log file.
EOF

not having a xorg.conf means that this destro does not use it , and uses a different method of getting this to work. what that is I do not know.


#6

not having a xorg.conf means that this destro does not use it , and uses a different method of getting this to work. what that is I do not know.

Believe it or not you have already found the answer to this question:

it showing going through just about every ATI Radeon chip set

These are not different chipsets. They are different drivers.

Xorg tries to autodetect what hardware you have and then tries several drivers until one works. This whole process is done very quickly and you only notice it if you have to read the logfiles.

‘fglrx’ is the proprietary ATI driver. It has the best performance, but is also buggy and is missing some features. You need to explicitly install this if you want it. The Arch Linux wiki has lots of good information on ATI drivers.

‘ati’ is the open-source ATI driver. This is built into your kernel. It’s much less error prone and less annoying to use, and a couple of years ago AMD starting working on it. It’s not quite as good as fglrx in terms of performance, but for many users it’s good enough. I’ve used it quite happily for the past few years.

There are some new drivers coming out (AMD is slowly abandoning fglrx IIRC) but they are still experimental and only work on some hardware.

‘vesa’ and ‘fbdev’ are backup drivers that will work on almost any card, but very slowly and often with reduced featuresets. They are effectively ‘software rendering’, using your CPU to do the work instead of your GPU.


#7

I needed a file /etc/X11/xorg.conf.d/radeon.conf containing something like this:

Section "Device"
         Identifier "radeon"
         Driver "radeon"
EndSection

There might need to be a BusID specifier. See the man page:

man radeon


(Userx) #8

@Veyrdite @unknown2345

its late here but a quick post on ATI. I have my ATI and vesa default video xorg drivers installed. My Laptop does not have this problem, it is still then obliviously still supported, so I wonder why this USB install is having this problem. Tomorrow I guess i’ll have to look through the LAPTOP config files to see what I see in how they get this to work. then mimic it to see if that will work.

FUN Fun fun…

I’ll keep it posted in here.
Thanks


#9

@Veyrdite Just a question about startx and the .xinitrc file:

exec openbox-session

When I start an X session like this I always have some problems.

For example I do not have the permissions to shutdown/reboot the system, and when I run the command ‘ck-list-sessions’ I can see my consolekit session is not active !

The solution I found is to put a line like this in the .xinitrc file:

exec ck-launch-session openbox-session


#10

Years ago I did it with ckit.

My current solution is to put this line at the end of my /etc/sudoers file (using visudo):

%power ALL=NOPASSWD: /usr/bin/halt, /usr/bin/reboot, /usr/bin/poweroff, /usr/bin/pm-hibernate

Any user in the ‘power’ group can now just type ‘sudo poweroff’, ‘sudo reboot’, etc and the computer will act without having to enter a password.

Sidnote: you will need to create a group called ‘power’ and add your user to it.

groupadd power
gpasswd -a username power

I prefer this over consolekit for a few reasons:

  • One less process running and installed (arguably more secure)
  • Consolekit is no longer maintained (although a fork called consolekit2 exists), freedesktop.org wants you to use systemd-logind instead.
  • In my mind the sudo solution is more desktop environment agnostic, however I’m sure most DE’s are hardwired to only accept doing things one way.
  • I’m not a fan of tracking ‘sessions’ as a way of providing permissions: a user should just have them or not have them. This is also more reliable: consolekit used to break for me sometimes
  • I’m not a fan of using DBUS/any Redhat software for permissions stuff. Again, opinion.

#11

Sorry I go to sleep now… :sleeping_accommodation:


(Userx) #12

I’ve tried that. it is in my other post on this subject. it goes through everything just like before, then spits out that output that ck-launch-session gives you after X shuts down.


(Userx) #13

Stupid, Stupid, Stupid…
the word xterm popped into my head before I even posted this question. While I was messing with this USB Stick. then I just dismissed it.

then installed base system onto VM, got it working, by adding xterm.

Stupid Stupid Stupid…
had to do this after I got fluxbox up and runing to get a web browser to work
dbus-uuidgen > /var/lib/dbus/machine-id


#14

In my /etc/X11/xinit/xinitrc.d/ folder I have only one file: 90-consolekit

# -*- sh -*-
# Xsession.d script for ck-launch-session.
#
#
# This file is sourced by Xsession(5), not executed.

CK_LAUNCH_SESSION=/usr/bin/ck-launch-session

is_on_console() {
	session=$(dbus-send --system --dest=org.freedesktop.ConsoleKit \
		--type=method_call --print-reply --reply-timeout=2000 \
		/org/freedesktop/ConsoleKit/Manager \
		org.freedesktop.ConsoleKit.Manager.GetCurrentSession \
		| grep path | awk '{print $3}' | sed s/\"//g)
	x11_display=$(dbus-send --system --dest=org.freedesktop.ConsoleKit \
		--type=method_call --print-reply --reply-timeout=2000 \
		$session org.freedesktop.ConsoleKit.Session.GetX11Display \
		| grep string | awk '{print $2}' | sed s/\"//g)

	if [ -z "$x11_display" ] ; then
		return 0
	else
		return 1
	fi
}

# gdm already creates a CK session for us, so do not run the expensive D-Bus
# calls if we have $GDMSESSION
if [ -z "$GDMSESSION" ] && [ -x "$CK_LAUNCH_SESSION" ] && \
 ( [ -z "$XDG_SESSION_COOKIE" ] || is_on_console ) ; then
    STARTUP="$CK_LAUNCH_SESSION $STARTUP"
fi

This script is launching a ConsoleKit session ?
So if I don’t want ConsoleKit automatically launched I must keep a simple .xinitrc file WITHOUT the top lines:

Executed by startx (run your window manager from here)
if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  done
  unset f
fi

Just a simple .xinitrc file, for example:

xset -dpms &
exec startxfce4

#15

@cr6 yep that should all work.


#16

@Veyrdite To shutdown/reboot I stole a little script on an old “Gparted Live” ISO.

This script is called “gl-shutdown-menu” and uses “zenity” to produce a graphical dialog box:

#!/bin/bash

choice="$(zenity --list --title "Select item from the list" --text "Exit" --radiolist  --column "Pick" --column "Action" TRUE Reboot FALSE Shutdown FALSE Logout)";

case $choice in
	"Reboot")
		reboot
		;;
	"Shutdown")
		halt
		;;	
	"Logout")
		gl-killx
		;;
esac

And the contents of “gl-killx” is:

#!/bin/bash
pkill X
exit

Cool, thanks to the Gparted-Live developers! :christmas_tree: