Home | News | Download | Packages | Forum | Wiki | Github

[SOLVED] No audio on x220

(rakor) #1

Hi there,
I installed void (glibc) onto a Thinkpad x220. I am happy with it but have some issues left.

It seems as the system does not find an audiocontroller. So I have no sound. My user in the group “audio”.

Can you help me?


how you have come to that conclusion? :neutral_face: what did you try?


What services do you have running?
Is the alsa service enabled?
Have you check that the channels are not muted?

(rakor) #4

Thanks for the help!
In Cinnamon the sound-configuration shows no device (no output and no input). So I can’t unmute because there are no devices shown. I don’t habe an alsa-service in /etc/sv
Services activated are those:

ls /var/service/
acpid@ agetty-tty2@ lightdm@ rpcbind@ ufw@
agetty-tty1@ dbus@ NetworkManager@ udevd@ vboxwebsrv@

dmesg tells me:
[ 14.513798] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops vgt_balloon_space [i915])
[ 14.648775] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUG disabled
[ 14.648777] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUGFS disabled
[ 14.648778] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TRACING disabled
[ 14.648779] iwlwifi 0000:03:00.0: Detected Intel® Centrino® Advanced-N 6205 AGN, REV=0xB0
[ 14.667090] snd_hda_codec_conexant hdaudioC0D0: CX20590: BIOS auto-probing.
[ 14.667549] snd_hda_codec_conexant hdaudioC0D0: autoconfig for CX20590: line_outs=1 (0x1f/0x0/0x0/0x0/0x0) type:speaker
[ 14.667551] snd_hda_codec_conexant hdaudioC0D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 14.667552] snd_hda_codec_conexant hdaudioC0D0: hp_outs=2 (0x1c/0x19/0x0/0x0/0x0)
[ 14.667553] snd_hda_codec_conexant hdaudioC0D0: mono: mono_out=0x0
[ 14.667554] snd_hda_codec_conexant hdaudioC0D0: inputs:
[ 14.667556] snd_hda_codec_conexant hdaudioC0D0: Internal Mic=0x23
[ 14.667557] snd_hda_codec_conexant hdaudioC0D0: Mic=0x1b
[ 14.667558] snd_hda_codec_conexant hdaudioC0D0: Dock Mic=0x1a
[ 14.668915] snd_hda_codec_conexant hdaudioC0D0: Enable sync_write for stable communication
[ 14.737397] input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:1b.0/sound/card0/input9
[ 14.738047] input: HDA Intel PCH Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input10
[ 14.738166] input: HDA Intel PCH Dock Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input11
[ 14.738282] input: HDA Intel PCH Dock Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input12
[ 14.738584] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input13
[ 14.738704] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1b.0/sound/card0/input14
[ 14.738831] input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1b.0/sound/card0/input15
[ 14.738951] input: HDA Intel PCH HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:1b.0/sound/card0/input16

If I start the voidlinux cinnamon-live-image I have sound. So something seems to be missing…

[SOLVED] No UMTS on Lenovo x220

Try enabling the alsa service.

sudo ln -s /etc/sv/alsa /var/service

Do you have sound now?

(rakor) #6

I have no alsa service.

ls /etc/sv
acpid/ agetty-tty1/ agetty-tty5/ agetty-ttyUSB0/ dhclient/ ip6tables/ NetworkManager/ sshd/ ufw/
agetty-console/ agetty-tty2/ agetty-tty6/ cgmanager/ dhcpcd/ iptables/ nfs-server/ statd/ uuidd/
agetty-generic/ agetty-tty3/ agetty-ttyAMA0/ consolekit/ dhcpcd-eth0/ lightdm/ rpcbind/ sulogin/ vboxwebsrv/
agetty-serial/ agetty-tty4/ agetty-ttyS0/ dbus/ dmeventd/ lvmetad/ slapd/ udevd/ wpa_supplicant/

I think I am missing a packge:

xbps-query -l | grep alsa
ii alsa-lib-1.1.5_1 The Advanced Linux Sound Architecture (ALSA) library

I thought cinnamon would bring all dependencies needed


To be honest I have no idea what it brings. I’m using awesome wm and have never used any of the DE ISO’s.
Install alsa packages, enable the service and check if audio is working. I suspect that your other problem (the other thread you posted) could be solved by enabling the NetworkManager service.

(rakor) #8

Thanks, but what alsa-package do I have to install :confused:

xbps-query -Rs alsa
[-] AlsaMixer.app-0.1_3 Simple dockable mixer application for Linux with ALSA drivers
[-] a2jmidid-8_7 Daemon for exposing legacy ALSA sequencer apps to JACK MIDI
[-] alsa-firmware-1.0.29_2 The Advanced Linux Sound Architecture (ALSA) firmware
[*] alsa-lib-1.1.5_1 The Advanced Linux Sound Architecture (ALSA) library
[-] alsa-lib-devel-1.1.5_1 The Advanced Linux Sound Architecture (ALSA) library - development files
[-] alsa-lib-python-1.1.5_1 The Advanced Linux Sound Architecture (ALSA) library - python smixer plugin
[-] alsa-oss-1.0.28_1 OSS compatibility library for ALSA
[-] alsa-plugins-1.1.5_1 Advanced Linux Sound Architecture (ALSA) extra plugins
[-] alsa-plugins-ffmpeg-1.1.5_1 Advanced Linux Sound Architecture (ALSA) extra plugins - libavcodec/a52 plugins
[-] alsa-plugins-jack-1.1.5_1 Advanced Linux Sound Architecture (ALSA) extra plugins - Jack output plugin
[-] alsa-plugins-pulseaudio-1.1.5_1 Advanced Linux Sound Architecture (ALSA) extra plugins - Pulseaudio output plugin
[-] alsa-plugins-samplerate-1.1.5_1 Advanced Linux Sound Architecture (ALSA) extra plugins - libsamplerate resample plugin
[-] alsa-plugins-speex-1.1.5_1 Advanced Linux Sound Architecture (ALSA) extra plugins - Speex resample plugin
[-] alsa-tools-1.1.5_2 Advanced ALSA tools for certain sound cards
[-] alsa-tools-devel-1.1.5_2 Advanced ALSA tools for certain sound cards - development files
[-] alsa-utils-1.1.5_1 The Advanced Linux Sound Architecture (ALSA) utilities
[-] apulse-0.1.11_1 PulseAudio emulation for ALSA
[-] balsa-2.5.5_1 An email client for GNOME
[-] cava-0.6.0_2 Console-based Audio Visualizer for ALSA
[-] cava-gui- Console-based Audio Visualizer for ALSA (GUI branch)
[-] patchage-1.0.0_2 Modular patch bay for audio and MIDI based on JACK and ALSA
[-] pmidi-1.7.1_1 Command line midi player for ALSA
[-] python-alsa-1.0.29_2 Official Python bindings for ALSA
[-] qastools-0.21.0_1 Collection of desktop applications for the Linux sound system ALSA

According the other problem: I have NetworkManager already running. :frowning: But doesn’t help.


xbps-query -s alsa

is faster.

xbps-install alsa-utils
ln -s /etc/sv/alsa /var/service

then run alsamixer to see the :loud_sound: audio volume.

(rakor) #10

OK, now I can see my soundcard in alsamixer and change volume there. But in cinnamon there is still no soundcard visible and I have no sound.

Thanks for the hint with xbps-query :slight_smile:

(rakor) #11

Heyho… Sound is playing… I needed to install alsa-plaugins-plulseaudio additionally…

Thanks for all your help


Sorry, I was away for a few hours… skiing :upside_down_face:
Glad @cr6 followed up and helped you with the needed packages and that the issue is solved :rofl:

(rakor) #13

Wouldn’t it be a good idea to set “alsa-plugins-plulseaudio” as dependency for cinnamon?

(Erin) #14

Would suggest it is not a dependency but you can ask the maintainer to consider your request here.


Bad idea adding alsa-plugin-pulseaudio to any dependency as it breaks this popular manual pulseaudio configuration:
PulseAudio as a minimal unintrusive dumb pipe to ALSA