[Solved] Musl x86_64 build stuck at july 1st?


#1

I haven’t found any mention of it, so my apologies if it’s a duplicate :smiley: – I did look here, on twitter, github, and tried googling

Anyway, xbps-install -Su hasn’t found anything for a few days, looking at the repos there doesn’t seem to be any build after July 1st, and https://build.voidlinux.eu/builders/x86_64-musl_builder says some builds seem to be taking over 167 hours, can anyone look into it?

(and maybe, in the long term, add a timeout for builds)

Cheers


(maxice8 alter) #2

know problem, the host of the builders lost connection.


#3

Doh, seems I was the only one who didn’t know it!


(Gus Fun) #4

It begun to look odd to me too as I keep two installations, glibc and musl, and the first was getting updates of similar stuff installed on musl.
Everything still very functional though.


#5

Any timelines, as to when it could be up again?


(maxice8 alter) #6

not that i am aware, i don’t work on the infra.

ask on #xbps


#7

Thanks, I’ll check.


#8

musl updates came through this morning, a bunch of them of course.
Everything working just fine on my system.
Thank you for fixing the builder, you guys are awesome :hugs: