Home | News | Download | Packages | Forum | Wiki | Github

[SOLVED]Minor issue: Void boots without passphrase on LVM/LUKS


#1

Okay now my LVM/LUKS starts, but I do not get prompted for my passphrase. It just boots straight to the OS without any password prompt even its encrypted (luks). How? And why? I want to have a password request.

OLD ISSUE:

I have successfully installed Void on LVM & LUKS now, however on start I get the following errors:

1.) The LUKS Partition errors out on e2fsck complaining it’s already open.

I can ignore this but then I get another error with runsvdir:

2.) runsvchdir: fatal: unable to chdir: /etc/runit/runsvdir: file does not exist

I’m kinda lost. I looked in void-mklive but there is not really any info on that and not any mkdir or anything.

I did install the Void System like the following:

https://gist.github.com/Anachron/b8069fcbb5654772417a46ef00a0351a

Edit: I have realized that the scripts in https://github.com/voidlinux/void-runit/tree/master/core-services are most possibly all run at this stage (for issue #2) already.

(Sorry for the pictures, I didnt setup my host OS yet and I may not do that until I have an idea how to setup Void Linux on this Laptop)

Edit #2: I solved it by running xbps-reconfigure -a. Thanks @Duncaen


[Solved] Cant get LVM on LUKS to work