Home | News | Download | Packages | Forum | Wiki | Github

[SOLVED] Locale problem - ccsm won't work



i am novice to Void Linux, but come from a very similar background - Arch Linux.

I installed Void via minimal install iso, my DE is MATE.

So i decided to go with Compiz as my WM but have some problems running ccsm. When run it in terminal i get this error:

ccsm:3506): Gtk-WARNING **: Locale not supported by C library.
Using the fallback ‘C’ locale.
Traceback (most recent call last):
File “/usr/bin/ccsm”, line 101, in
import ccm
File “/usr/lib/python2.7/site-packages/ccm/init.py”, line 1, in
from ccm.Conflicts import *
File “/usr/lib/python2.7/site-packages/ccm/Conflicts.py”, line 26, in
from ccm.Constants import *
File “/usr/lib/python2.7/site-packages/ccm/Constants.py”, line 81, in
locale.setlocale(locale.LC_ALL, “”)
File “/usr/lib/python2.7/locale.py”, line 581, in setlocale
return _setlocale(category, locale)
locale.Error: unsupported locale setting

My locale.conf:




Which is really strange that this two outputs are so different.

Do you have any suggestions?

Thank you.


I think it’s not necessary to set LC_* if they do not differ from LANG. Furthermore, you used en_GB.UTF8 for LC_* and en_GB.UTF-8 for LANG. Note the missing dash. The locales in /etc/default/libc-locales are all spelled …UTF-8 (with dash). So maybe it’s worth a try to spell it with a dash? (Or just remove LC_* and just use LANG.)


Hey, thanks for reply.

So i removed all LC_* but the problem persist.

The weird thing is that locale -a gives output without “-” just “.” although i ran : xbps-reconfigure -f glibc-locales

Can you please check on your comp what is the ouput of locale -a


It’s utf8 without the dash. And I have just LANG set in locale.conf.

But you can try to set LC_ALL=en_GB.UTF-8 in addition to LANG.

Maybe a silly question but did you uncomment en_GB.UTF-8 in /etc/default/glibc-locales?


I did this but didn’t help.

Just for a testing purposes i created another user and here ccsm launched without problems. So i guess there is a locale file in the user level but can not find it.

Any suggestion where to search for it?


A per user locale can be set in ~/.config/locale.conf. You can also check out the ArchWiki. Maybe you can find something helpful there.


Hey, finally made. After removing files as crazy i found out that .pam_environment files was guilty.

Everything working now smoothly :slight_smile:

Thank you for all the help.

For now Void rules!