Home | News | Download | Packages | Forum | Wiki | Github

[SOLVED] LibreOffice crashes silently on startup


#1

Very minimal installation using void-live-i686-20170220.iso. Installed X, i3, and LibreOffice.

LibreOffice consistently crashes on startup no matter how I try to launch it. For example, libreoffice --writer should launch LO and create a new Writer document. The splash screen appears and the progress bar runs its course, but the window only opens for a split second before it disappears and the command exits. Absolutely no output is given in the terminal. Same result with libreoffice --calc or any of the other parameters.

I’m at my wits’ end here, does anybody else on i686 glibc have problems with LO?

Edit: Solved! The solution is detailed down in post 22.


#2

hello, surprisingly I installed LibreOffice, 2 or 3 weeks ago, without even trying to launch it.
I just tried and have the same issue…


#3

Good to know it’s not just me! Hopefully we can get somebody in here that knows what’s going on, lol. Without any output (errors or otherwise) in the terminal, my troubleshooting skills are pretty limited.


#4

well, it’s a bit weird, all is working great again, i’d just updated the last kernel


#5

Not working for me.

$ uname -r
4.12.12_1

#6

well, I don’t know what’s going on… sorry for not helping you more…

when I launch “libreoffice --writer” in a terminal, it’s working now, it does not crash any more… I changed nothing else…

I’ve got the same version


#7

Not your fault, I appreciate the help so far!

Anybody else able to test LibreOffice?


#8

Same here. Perhaps it’s got something to do with the recent update to python 3.6? It was rebuilt afterwards but maybe something wasn’t yet quite right at the time? I’m trying to see if a rebuild will help, but it takes a lot of time on my old machine :wink:


#10

Have you tried xbps-install -Su as there was a problem with python3.6 recently that broke alot of programs including LibreOffice.


#11

@bluemoon Perhaps Python is the culprit. I was not aware of any Python 3.6 update causing breakages but it’s been mentioned twice so it must be the case. Please do let me know if the rebuild works, I will try it on my machine and maybe we can get this fixed for everybody.

I do update my computer at least once a day, so I think the problem exists in the repos and won’t be solved by updating just yet. @WantToHelp does LO work for you?


#12

LibreOffice works on both kernel 4.12.12_1 and 4.13.1_1 for me.

Also are you running directly off the live image or did you install from it, because I’ve had problems with programs running off the live images before.

And are you using the main repo (https://repo.voidlinux.eu/) or a mirror?


#13

Are you x86_64 or i686?

I am using 4.12.12_1. Not from a live image, from an installation. Using the main repo.


#14

x86_64 for both kernels.


#15

I’ve just noitced that the 32bit package of LibreOffice does not install clucene-32bit-2.3.3.4_5 whereas the 64bit package installs clucene-2.3.3.4_5.

You could try installing clucene-32bit-2.3.3.4_5 in case it’s requried.


#16

Installing clucene did not help. I’m using i686 so clucene-32bit doesn’t exist for me.

The only mention of clucene I see in the package template is here:

*-musl)	# use shipped clucene, because CLucene/analysis/cjk/CJKAnalyzer.h
	# is missing in the musl clucene-devel files
	;;
*)	configure_args+=" --with-system-clucene"
	makedepends+=" clucene-devel"

And it only seems to affect musl. Are you running x86_64-musl? That might explain why LO works for you with the clucene caveat.

Perhaps the problem is only present on i686?


(Jacob Moen) #17

I am on x86_64-libc and LibreOffice works a charm, so it could be a i686 specific issue.


#18

I’m running x86_64-glibc for both kernels so I think you’re right that it’s a i686 problem.


#19

Thanks for the confirmation! At least now we have something to go on, in lieu of useful debug output :stuck_out_tongue:

I’m at work at the moment but will resume finding a solution later today!


(James Aanderson) #20

Not sure if this is helpful, but I took to installing libreoffice from the vendor site a long time ago, on a different linux distro far far away. Still do it that way out of habit.

The way I do it is download the RPM, use rpm2tgz on it, and then extra the bins into their own directory. Then I modify my path to see that path.

Has worked for a few versions so far. YMMV.


(Jacob Moen) #21

I would never, ever do that to my Void box :crazy_face:
Especially when the XBPS packages works so well.