Home | News | Download | Packages | Forum | Wiki | Github

[SOLVED] KDE Plasma 5 on x86_64-musl


(Adomas Jackevičius) #1

Hello,
Do any of you use KDE Plasma 5 on voidlinux (musl version)? How does it work? Is it usable for daily use? Last time I tried it, I had no success to get it working…: KDE Plasma: All shell packages missing

I wonder if situation has changed, would love to try voidlinux again :slight_smile:


#2

KDE Plasma works fine for me on both glibc and musl, haven’t encountered any bugs yet.


(Adomas Jackevičius) #3

Thanks for reply. Downloading latest ISO to try out on my hardware :wink:


(Adomas Jackevičius) #4

Well this time I fail even more… This time I could not pass the sddm problems:

sddm-helper exits with status code 11 (from /var/log/sddm.log)
dmesg shows sddm-helper segfaults

Creating /var/lib/sddm and making it writable did not help… While last time it helped.

First I do sv up dbus and then sv up sddm
At the last point I was seeing cursor in the middle of tty1, but no other graphical things :frowning:

Maybe someone has a solution to this?

Wanted to get more info about the problem, but somehow as I launch Xorg, I see no cursor (???) I have both xf86-input-libinput and xf86-input-evdev, in Xorg log no errors reported.


#5

I eventually got SDDM to work after creating /var/lib/sddm/ doing chown sddm:sddm /var/lib/sddm and installing the xorg meta-package.

EDIT: At the moment SDDM only works with elogind so I had to install it and replace consolekit2 with it by unlinking /var/service/consolekit and /var/service/cgmanager

I’ve given up on SDDM now as I’ve had so many issues with it. I personally use LightDM instead, which seems to be more reliable.


(Adomas Jackevičius) #6

Oh, installing elogind and xorg meta package has solved few issues.

Somehow I was always installing only xorg-minimal and xinit for Xorg setup, later getting parts which I needed, but xorg meta package has helped me.

At this point when I start sddm, I am still sort of in tty1 view, but I am in tty7 with a working mouse cursor :smiley:

Still sddm-helper exits with 11, but now it gives me more info in dmesg (latest 5 lines):

[    6.357045] IPv6: ADDRCONF(NETDEV_CHANGE): eno1: link becomes ready
[   13.947724] elogind[726]: New session 1 of user root.
[   41.274981] elogind[726]: New session c2 of user sddm.
[   41.467965] sddm-greeter[905]: segfault at 7f0cf2261770 ip 00007f0ce68f4ff6 sp 00007f0cf2261760 error 7 in nouveau_dri.so[7f0ce65a4000+c1c000]
[   41.485660] elogind[726]: Removed session c2.

Seems that sddm-greeter does not like something about nouveau dri… not sure how to continue.

Any ideas? Is it possible to use nvidia closed source drivers on musl version or is it only glibc compatible?


#7

Do you use PRIME? As on the SDDM github page it mentions having to run a script for some reason: https://github.com/sddm/sddm#nvidia-prime

Check if the sddm user is in the video group.

You can’t use close source software on Musl because it will be linked to Glibc

Nvidia drivers never want to work, they drive me crazy :crazy_face:


(Adomas Jackevičius) #8

Not sure what is PRIME, I don’t use that. Good idea about sddm users groups… I will check if it is part of video group.

I expected that closed source drivers will be unavailable with musl… Somehow sad :frowning:

EDIT: adding user sddm to group video, did not solve anything. Same problem, same segfault.


#9

I’m out of ideas now, you could try running sddm --test-mode and see if that displays anything useful.
Maybe you should open an issue at https://github.com/sddm/sddm/issues
If you want to use Plasma but can’t get SDDM to work just use a different login manager in the mean time.


(Adomas Jackevičius) #10

Seems this problem is already solved. I did today a clean install of Void Linux x86_64-musl and SDDM works as it should. Whole KDE Plasma 5 setup is now operational :heart: