Home | News | Download | Packages | Forum | Wiki | Github

[SOLVED]Installation on virtualbox


(m4k5) #1

Hello Voiders.
Installing and running voidlinux until version linux4.8.17_1, proceeded without problems.
However, higher versions linux4 cause the system to freeze immediately after booting GRUB.
For example:

Perhaps a similar problem has been published HERE
What information would you need to help me?

Regards…


#2

Hi,

maybe do You want to try a qemu?

Install qemu
$ sudo xbps-install qemu

Create disc for VM
$ qemu-img create -f qcow2 /path/to/void.qcow2 20G (20G only example)

Install VM
$ qemu-system-x86_64 -enable-kvm -m 2048 -cpu host -daemonize -cdrom /path/to/voidlive.iso -boot -d /path/to/void.qcow2

Run VM
$ qemu-system-x86_64 -enable-kvm -m 2048 -cpu host -smp 2 -vga std -soundhw ac97 -daemonize -full-screen /path/to/void.qcow2

Options you can change:
-m RAM
-cpu your cpu type, e.g. skylake
-smp cpu cores

If you want VM to read usb stick add option (it must be run with sudo or as root):
-hdb /dev/sdx (/dev/sdx is your usb stick)

$ sudo vim /etc/sudoers.d/qemu

username ALL=(ALL) NOPASSWD: /sbin/qemu-system-x86_64 (or i686)


#3

@m4k5: I guess you mean installing from the current isos and then upgrading to the current 4.9 kernel.

I had problems (freezings) with the earliest 4.9 versions but not anymore. My Void VMs run fine in VBox with the current ones since weeks. Can you give us some more details of your VM setup? I guess you don’t have the guest-additions installed yet, don’t you?


#4

BTW, 4.9.6_1 kernel worked fine for me, but 4.9.7 was around maybe a week ago (also running fine). Is that one a fresh install?


(m4k5) #5

@rjb
I always preferred VB.
Qemu i will play at the weekend. Thank you for the lecture.

@Snap
As I wrote at the beginning.
Kernel number linux4.8.17_1, the maximum version of the operating
properly. Upgrading make freeze.
It does not matter whether voidlinux is installed by Internet or by
using void-live-i686-20160420-xfce.iso, or test version of
void-live-i686-20170130-xfce.iso

These packages have installed:

linux44-virtualbox-guest-modules 5.1.14-1
linux44-virtualbox-host-modules 5.1.14-1
virtualbox 5.1.14-1
virtualbox-ext-oracle 5.1.14-1
virtualbox-guest-iso 5.1.14-1
virtualbox-guest-utils 5.1.14-1


#6

Not using dkms? Maybe it helps. I’ve got some trouble with VBox kernel modules not loading running as guest. Removing everything VBox related and reinstalling the kernel headers first solved the issue for the VMs. There’s a thread somewhere in the forum about this last issue.

I’d try this route: (Sorry, I don’t remember the exact steps, I should have taken notes, but I didn’t… Hope I got it right) .

  • Remove all the VBox stuff first and maybe the kernel headers too.
  • Update the kernel xbps-install -Suv, just in case and install the headers and dkms.
  • Then xbps-install -Sv virtualbox-ose virtualbox-ose-dkms.
  • Run modules-load.
  • Sometimes they need to be rebuilt xbps-reconfigure -f virtualbox-ose-guest-dkms.
  • Reboot, cross fingers and fire up the VM.

This worked for me. Hope it helps.

Regarding qemu. I tried to switch for a few months and reverted back to virtualbox a couple of weeks ago besides it’s non-free stuff. The qemu documentation is fully disperse, usually outdated and hardly ever works. Needs a darn lot of research and test, fail, repeat. Plus, the recent updates made it a real mess. Of course there will always be enthusiast supporters, but for me it’s a no-go. Being there done that. I’m starting to learn LXC. Containers seem to be a better option. For now switching back to VBox feels like a true relief. Just my 2cents.


[SOLVED]How to update the system without updating the kernel?
(m4k5) #7

@Snap
VirtualBox - I have done all the instructions. Here is the result:


I think it is about this line:

Physical KASLR using RDTSC…

OKAY. The matter is not resolved.
I think, however, that the subject can be closed.
Thank you all for your support.


BOINC users - concerning segfaults and kernel 4.9
(m4k5) #8

Solution is in THIS TOPIC.

Thank you voiders.