Home | News | Download | Packages | Forum | Wiki | Github

[SOLVED] Installation on Shuttle Server Issues


(hiten) #1

I’ve got a new Shuttle Server, and I’ve tried relentlessly to install Void Linux onto it for a few days now, with no luck. My latest attempt had the void-installer command crash the terminal window; it just vanished without further notification. Upon reboot, the system was at a slow crawl. I noticed a good deal of errors dealing with ata2.00 and the checksum on boot: this was off by 96. I’m off my rocker with this. Is there something I’m doing wrong?

UPDATE: the errors I saw on boot included this one: EDID checksum not valid: remainder is 96


#2

Is the installation image (iso) correct? Use checksums to verify.

If yes, check if the burning/copying of those files to the medium is fine as well.


(hiten) #3

Yes, the iso is correct; the checksums checked out. I haven’t checked the burned output, but I will in the next day or two. I used the same iso to install Void on my current laptop (works perfectly) so I’m reluctant to accept the medium as an issue. As said before, I’ll check tomorrow and get back to you.


(Masato the Empty) #4

It’s quite messy, but something else you might want to try, if you feel up to it, is to insert echo commands in various places in the void-installer script to help determine where it fails. From what I can see, the installer script isn’t too bad for debugging (I’ve seen some pretty bad ones that I can’t make heads or tails of).
(to make sure you catch all of them, you could echo your messages to a file, or another /dev/ttyx - only use 8 if you’re trying to line them up with the rest of the output from the script, since that’s where it sends all its messages to)


(hiten) #5

Issue closed. Solution lied upon retrial with a newer ISO.


(Benjamin) #6