Home | News | Download | Packages | Forum | Wiki | Github

[SOLVED] Install LVM with void-musl problem


#1

Hi,

I’d like to install void-musl and set up LVM. When I try to execute this command:

xpbs-install -S -R https://repo.voidlinux.eu/current/musl -r /mnt base-system …

I got an error:
Failed to fetch file etc.

Thanks.


#2

Did you make sure you have internet connection before?


#3

Yes. I’m sure.

xbps-install -Suv works.


#4

It would help if you post the full error, but i guess the problem is that you don’t export XBPS_ARCH.
XBPS_ARCH=x86_64-musl xpbs-install -S -R https://repo.voidlinux.eu/current/musl -r /mnt base-system
This is necessary because your new root dir has no config files, on musl systems there is a config file, which sets the architecture /usr/share/xbps.d/musl-arch.conf.


#5

Thank You, Duncaen.

It works now :slight_smile:

Full error was:

ERROR: [reposync] failed to fetch file ‘https://repo.voidlinux.eu/current/musl/x86_64-musl-repodata’: Transient resolver failure

Thanks for clarification also.


#6

This is a different error, related to DNS, probably no nameservers in /etc/resolv.conf.


#7

You’re right. My mistake.

That error was

ERROR: [reposync] failed to fetch file ‘https://repo.voidlinux.eu/current/musl/x86_64-musl-repodata’: Not found.

Thanks again.