Home | News | Download | Packages | Forum | Wiki | Github

[SOLVED] Img2txt unable to load images


img2txt converts images to various text-based coloured files.

If I try to use it with any image I get a message like this: img2txt: unable to load image.jpg


From the man page:

You must compile libcaca package with support of Imlib2 to be able to
load a wide variety of image formats. Otherwise you will only  be able
to load regular BMP files.

Checking libcaca’s template there’s no imlib2. If you really need it you can add and compile it with xbps-src yourself. I opened a PR to add imlib2 to libcaca. Now let’s wait and see :wink:


I prefer to wait. Compiling is a pain.


libcaca can now be built with imlib2 support, but it’s only optional as it also needs libX11. So enabling it per default would make a text-only installation rather useless. If you want to have it you do have to build it yourself, sorry. But when you’ve cloned void-packages all you have to do is run ./xbps-src -o x11 pkg libcaca.


That was rather easy. It works now.