[SOLVED] Having trouble compiling mpv


#1

I’m trying to compile mpv from its source and while it does compile, waf doesn’t set up the environment as it should, thus crippling the final binary.
Some excerpts from the terminal log:

Checking for Lua                                                  : no ('luajit >= 2.0.0' not found) 
Checking for X11                                                  : no ('x11 >= 1.0.0 xscrnsaver >= 1.0.0 xext >= 1.0.0 xinerama >= 1.0.0 xrandr >= 1.2.0' not found) 
Checking for Xv video output                                      : x11 not found 
Checking for OpenGL Cocoa Backend                                 : cocoa not found 
Checking for OpenGL X11 Backend                                   : x11 not found 
Checking for OpenGL X11 EGL Backend                               : x11 not found 
Checking for OpenGL DRM EGL Backend                               : yes 
Checking for Vulkan context support                               : no ('vulkan' not found) 

I don’t get what’s happening. I clearly have luajit 2.0.5, xorg-minimal and nvidia drivers and yet it doesn’t detect them. I’m compiling with the mpv-build branch. The binary just says that there’s no rendering context and the other --vo options don’t work either.

I’ve uploaded the full log here.


(Kevin Moses) #2

Is there a reason why you’re trying to compile this instead of just installing it from the Repository?


#3

What lua version do you have installed? mpv won’t work with 5.3… luckly, you can actually have more than one installed. Look for it with xbps-query.

Why don’t you just use xbps-src to build it? You can modify the template to add or remove options if that’s what you’re looking for.
It’s soo much nicer… bonus: xbps will be aware of your package and won’t break it’s dependencies in future updates.


#4

Yeah, the one in the repo is outdated.

What version do I need? Also the one on git is outdated.


(maxice8 alter) #5

look at the dependencies of the mpv template

also won’t be getting update until we get ffmpeg-4 in, which is a massive change. doesn’t help that mpv uses unreleased software sometimes.


#6

The template is for 0.27 though.

Darn. Guess I’ll have to wait. I would like to use mpc-qt, but I don’t think I’ll be able to any soon

Hah, got it. I was supposed to get the *-devel packages. Still no idea of how to get vulkan support, though. I was considering getting the .deb for libvulkan-dev but I’m not sure if that’s a good idea.’


(maxice8 alter) #7

problably not


#8

I’ll probably end up doing it eventually anyway because I’m an absolute madman
also, I installed unified remote using the deb package


#9

hey! another old memory:grin:


EDIT: here’s an updated template:wink:

It works for me, on x86_64: