Home | News | Download | Packages | Forum | Wiki | Github

[SOLVED] Chromium fails after user login?


(nf999) #1

Hi,

I’m new to void, but like it a lot sofar!

I have installed chromium, it’s working, however after google signin, stop and restart of chromium, chromium fails to start. I’ve narrowed it down to delete of .config/Default/Web Data. If this file is deleted chromium starts again, alas with the requirement to sign in again.

Even narrowed it down to the 4 lines in the ‘Web Data’, if these are deleted chromium starts, though without login:
INSERT INTO meta VALUES(‘mmap_status’,’-1’);
INSERT INTO meta VALUES(‘version’,‘74’);
INSERT INTO meta VALUES(‘last_compatible_version’,‘72’);
INSERT INTO meta VALUES(‘Builtin Keyword Version’,‘98’);

[*] chromium-61.0.3163.100_2 Google’s attempt …

I have no such issues on debian with same google signin. Other signins on void fail identical.

My guess is I’m missing some dependency?

Anyone any idea? Can anybody help?


(nf999) #2

nvm, fixed it …

as an answer to anybody running in this same issue, 2 solutions:

  1. add gnome-keyring, which wasn’t installed in my case
  2. start (first-run) chromium with --password-store=basic
    Note that: --password-store=basic uses the plain unencrypted text store

somehow selecting what password store to use is not working as expected, chromium should select automagically, I needed to set the password store at first start of chromium.