Home | News | Download | Packages | Forum | Wiki | Github

[Solved] Cant get LVM on LUKS to work


#1

Hey guys,
I’ve been trying to setup my Void VM but it doesn’t quite want to boot …

This is the error I am getting:

The ID is from my LVM volume (root). It complains about an unsupported filesystem.
Using “ls” at the rescue doesn’t give me any usable drive. I can use the live-system and cryptsetup luksOpen /dev/sda1 luks and then work with it.

These are the guides I was following/using:

https://wiki.voidlinux.eu/Install_LVM_LUKS
https://wiki.voidlinux.eu/Manual_Install_with_encrypted_boot


And this is the history of my commands:

https://gist.github.com/Anachron/3148c53d7c27f2503b28acd6194dd206

Thanks all for your help!

Ps.) I wonder why dracut generates older initrams than xbps-reconfigure -f linux4.9? Is that normal?


(Benjamin) #2

What is cryptdevice= set to in grub?


#3

https://gist.github.com/Anachron/3148c53d7c27f2503b28acd6194dd206#file-install-sh-L84


(Benjamin) #4

Is your boot drive encrypted? If not try removing GRUB_CRYPTODISK_ENABLE=.
If so as Gentoo’s wiki notes "In grub 2.02 and greater, this parameter was renamed to GRUB_ENABLE_CRYPTODISK=" so I would try that. Afterwords remake your grub config.


#5

Yes my boot is encrypted. I will try with GRUB_ENABLE_CRYPTODISK, thanks!


(Benjamin) #6

No problem, let me know how it goes!


#7

I just did that and the same error occurs!
I believe the issue is when I generate /boot/grub/grub.cfg there is no insmod lvm and no insmod luks?
Or is that not a problem?


#8

Okay guys, I have rerun my VM setup and this time I can boot with LVM on LUKS, just having other issues (see [SOLVED]Minor issue: Void boots without passphrase on LVM/LUKS).
This can be closed.


(Benjamin) #9

Will do! Glad you got it fixed.
Topic is now be closed as per author’s request.


(Benjamin) #10