Home | News | Download | Packages | Forum | Wiki | Github

[Solved] Cannot USB Live Boot


#1

Can anyone help me with this? I have installed Void twice before on this machine just fine, but I decided to reload it recently (no real reason), wiped my disk and made a liveboot usb which doesn’t boot.

I have tried sudo dd if=void.iso of=/dev/sdb (using the proper iso name) both with and without bs=4M. I have checked that the usb stick is indeed /dev/sdb. I have tried writing the image on a few different machines and USB sticks.

I have hash checked the downloaded image.

I have been through my BIOS settings several times, USB is top priority and there are no settings that would restrict it from booting.

The screen only gives me a flashing bar cursor that will happily tick away for hours.

I am trying to install the live i686 command line image onto a ThinkPad X200s. This worked first time during my first time with void Linux a while ago. The other live void images also do not work.

If I write the live image directly to the hard disk I am using, it will boot. But it will then not install to disk, even when choosing the RAM option from the GRUB menu.

Other distributions like tinycore Linux boot fine, it is just Void, it seems.

SOLVED:
Used an iso from https://repo.voidlinux.eu/live/20170220/
Instead of from the current repo.
(Much thanks to cr6, for solution and others for replies and ideas!)


(Benjamin) #2

Have you checksum’d the image after writing it to the stick? It should come out the same as the iso.


#3

If it’s not the machine, and it’s not the USB stick, then it must be the image.

Have you tried downloading another copy, then comparing their checksums?

$ sha256sum firstimage.iso secondimage.iso

#4

By using which ISO, precisely ?


(Erin) #5

Double check it is not mounted $ mount before writing the image. Mine was and it caught me out several times. If it is/ unmount it $ sudo umount /dev/sdXN then dd away.


#6

I have, it says it is correct.


#7

Which command did you use, precisely?

bs=4M does not matter, you can exclude this parameter.


#8

Thank you!
I was using one from 20171007, but I have just tried one from 20170220, which worked fine to install and which I could then update.
I wonder why 20171007 doesn’t work for me? Weird…


#9

Just realised my original question didn’t show the command; it appears my markdown is a bit rusty.
I was using dd if=void.iso of=/dev/sdb. I will edit the original post.


#10

There are many differences between the old ISO and the new ones, for example the kernels and the firmwares…

That’s correct.
And this option can be useful: status=progress