Home | News | Download | Packages | Forum | Wiki | Github

[solved] Cannot find package for python, rubby, phpmyadmin, ectc

(Jean-Pierre Rivière) #1

Hi fellows!

I am trying to install some useful stuff on my first void linux box. It ha been installed without python, rubby, phpmyadmin. After an update (xbps-install -Syu) I am trying to see if I can install them with things like

xbps-query -s python

which return nothing. Is there some kind of list of software source to check and eventually alter to get these rather basic kinds of stuff? How can I know where I am looking at?

BTW such things would be great if explained in the void linux wiki. I haven’t seen a FAQ either.


Hi @beporix I would recommend you read the Wiki a bit harder, see how the XBPS package manager works. xbps-query as the name implies, it is used to query packages, not to install them! That is done through xbps-install pkgname. If what you want is to search packages you may use xbps-query -Rs pkgname. Right now I believe phpmyadmin is not available in the repos.


(Jean-Pierre Rivière) #4

If I spoke of xbps-query -s python as an example, this is because of a longer story. Which I will tell here because it does ignite another question about xbps stuff.

First, I wanted to install phpmyadmin. So I did

$ xbps-install php-myadmin
unable to locate 'phpmyadmin' in repository pool

So I told me that perhaps it had another name in void linux. I finally discovered xbps-query, read the man page several times, had some tests, and came along with

xbps-query -s php

to see if that was a naming problem.

Now, read this. On my machine, there is yet no python.

xbps-query -s python

return nothing. But

xbps-install python

does function! And now

xbps-query -s python

does function too. I understood that I could only use one option. So did not ventore into -Rs which is indeed the solution. In fact, I did not realize that there were options and mode letters. This syntax is really weird. -Rs looks like an option. So /-sR should work as well and identically for consistency’s sake.

thanks. phpMyAdmin should have been checked by my query with php… if I could forge it right!

to both of you:
xbps-query -Rs php
does not reveal any phpMyAdmin. and
xbps-install phpMyAdmin
is unable to locate phpMyAdmin in repositorypool.
Yet I checked it is really there as Erin told.

How can I know and edit my repository pool? Well I checked with more attention and got it right finnally:
xbps-query -RL
0015 https://repo.voidlinux.eu/current (RSA-signed)

So… why cannot I see phpMyAdmin?



in xbps-query do not use the -s flag only, unless you know what you are doing. use -Rs the -R indicates xbps to look into the remote repository.

(Jean-Pierre Rivière) #7

xbps-query -s just look for your installed packets, I’ve seen now.

OK, before installing phpmyadmin, I want to be able to install php over apache without mysql. I have installed php, php-apache, php-embed and apache.

But my .php file are not processed by php. I notice that apache is using the old fashion http.conf only stuff, so no mods-enable, etc. So I’m a bit lost here. Is that a qestion of a missing packet, an other link to be done manually? Where could I gather this kind of knowledge? Googling is no great help here and the forum dos not help in that case so far. My apache is serving files just fine, it just doesn’t use php for php files!

(Stefan Mühlinghaus) #8

Aside from installing the php packages you also need to configure Apache to use PHP in /etc/apache/httpd.conf. Include the following below the already existing LoadModule-directices:

LoadModule php7_module /usr/libexec/httpd/modules/libphp7.so

And at the bottom add:

Include /etc/apache/extra/php7_module.conf

Then restart apache.

(Jean-Pierre Rivière) #9

Thank you @jazzman.

The Include directive in /etc/apache/httpd.conf is doing fine, but if I add the necessary LoadModule, then Apache is no more answering to queries (there is no connexion to the server according to the web browser). I cannot see anything wrong in */var/log/httpd/log or with dmesg | tail.

the php .so file is there yet, and php is really there too.

But this is now an Apache config problem, so I’m gonna creating a new thread and mark this one as solved.

(Jean-Pierre Rivière) #10

My new Apache config thread is here: Running php scripts with Apache