Scanner printer problems


Printer scanner Epson L210 after waiting 2 years gutenprint finally arrived on Void.
So installed it went through the various hoops works fine with the gutenprint dedicated driver, next I find iscan, iscan-data program in repro install iscan iscan-data but no menu entry after install iscan works fine from terminal great no problem.

Go to use printer OOPs its disapeared completely as in no entry in cups interface or print manager, after a google I read a post same problem from about 4 years ago, it was a sane bug the scanner taking preference over the printer. this bug should be fixed by now. I know it is as i use the printer scanner on Arch Linux.
I removed iscan and its depends printer is back and working correctly.

Next I tried simple scan all working fine including printing. strange then I remembered Iscan used its own sane backend and that must be causing the problem can you fix the sane package for iscan.
As simple scan is just to basic for my needs.

(Jacob Moen) #2

I have an Epson too. :slight_smile:

What did you install?
Is that all you need to do?
Do you have a link?

(Your post is almost impossible to read, by the way)


No its not all you need to install you need the cups stuff, you need to enable cups at boot time,
In terminal as root ln -s /etc/sv/ cupsd /var/service/ press enter.

If you look there is a forum post also I think,
To check your printer is connecting do lsusb in a terminal and it should show up

Install print manager GUI its easier to use than the cups web page.

You also need to add you self to some groups lp and lpadmin. use a editor as root.

Then hope and pray your printer comes up, if you get a choice of cups for your Epson or Gutenprint opt for Gutenprint over cups as cups are very basic drivers.
Sorry I did not mean to post it my kids pressed reply and I forgot to check

(Jacob Moen) #4

Thank you!
I’ve been dying to get my Epson working on Linux :smile:

I am currently using a elaborate combination of Nextcloud and an Epson app on my phone. :wink:

I hope that you solve your original problem, though - as I also have a vested interest in it.


I had to fight, but the following worked for me :

  1. Install sane
  2. install scanner driver (hplip for me, may try xbps-query -Rs epson)
  3. uncomment epson in /etc/sane.d/conf.dll
  4. install xsane or simple-scan or gscan2pdf if you want some gui

Hope it helps.


NO No I don’t use HP I use Epson, I installed the correct packages Iscan, iscan-data and Gutenprint, they are the correct packages.
Iscan draws in its own version of sane for Iscan this version is faulty as it blocks the printer.
I already had sane, simple-scan installed but it is to basic for my needs.
I need Iscan it does work but I need the printer to work as well with it as it does in every other Linux distro, For goodness sake I’ve waited 2 years for void to include gutenprint to use the printer. now I just want Iscan, the epson scanner package to work with it.


If you want to test SANE functionality run scanimage from console. It will give you error output.


I think we are on crosswires here Sane is fine it works with simple scan just fine but simple scan is basic, Epson has its own scanner program its in the repro for epson scanners its called Iscan i use it all the time with every other Linux distro.
But with Iscan installed on void the printer is blocked totally only the scanner works.
So for me the Iscan package needs rebuilding so it works and my printer is not blocked or removing totally. what is the point of packages that don’t work.
This is not a rant in anyway so don’t take it the wrong way I can manage with out Iscan if needed but others would not tolerate broken packages. Then void gets bad press on the net that is all.


So run /usr/bin/scanimage to see what SANE reports from that backend.

It’s an alternative to iscan for the long run as well, although I hear ya that iscan package needs updating.

# list known scanners
scanimage -L

# opts for one device using device-name from above
scanimage --help --device-name "foodevice:DEADBEEF_123456"

# test scan American letter size 8.5 by 11.0 inches (215.9 by 279.4 mm)
scanimage -d "foodevice:DEADBEEF_123456" --resolution=150 -x 215.9 -y 279.4 --format=jpeg  >/tmp/scannedpic.jpg

Epson support site says the latest firmware on your model is

Version: SM18E8
Release Date: 30-Oct-2014

Make sure that’s installed too.

If SANE works then GIMP has a GUI interface as well.


Thanks for trying to help But Iscan works fine as long as i don’t need a printer Its a reported bug from 2015 I had the same problem at that time using any distro, its long fixed and the package needs updating then it will be fine.

What I don’t understand is this is a repro package then why is it not up-to date just seems odd to me.

I have used void for 2 years its only when gutenprint became available and i tried to finally get printing sorted so to be able to use Void as a real alternative this came up.
I need Printing I need a good scan program for children to use flawlessly.

(Kevin Moses) #11

I have a question. I’M a total newb to void Linux. I’m currently an Arch Linux user.

My question is this: I have an Epson scanner that Sane does not provide drivers for. Also, iscan doesn’t have drivers for.
My Epson requires the image scan v3 driver package.
Is that package in the void repositories by chance. Or am I going to have to compile it from source. And how hard would that be?


Have you checked if gutenprint supports it?

I have packaged gutenprint for void linux so most printers are just a simple pkg install away!


Its not printer drivers he wants its scanner, but from what he fails to describe like scanner model, what steps taken, like permissions etc, looks like he actually uses a Arch child distro not Arch.

(Kevin Moses) #14

Yeah, I have the es-400 WorkForce scanner by Epson.
In Arch, it works with the image scan v3 for Linux driver.

I just know that iscan and sane doesn’t support it. Also, I am planning a command line only void setup, no gui.

(Kevin Moses) #15

I’m am using arch itself, but my arch is command line only, no gui.


So your using image-scan not “imagescan for Linux”, it gets confusing I have not done this but they say you can use AUR pkg builds as a guide The rpms are available from Epson by the way, hopefully they are for “image scan for Linux” as its a Epson program, “image-scan” its Utsushi 0.38.0
And this is a Void pkgbuild for the 0.36 version[]=filename%3Atemplate+path%3A%2Fsrcpkgs&q[]=Utsushi+&s=indexed

(Kevin Moses) #17

You are right on it. Utsushi is basically a frontend for sane that incorporates the new Epson image scan which is image scan v3. I believe the old image scan went up to 2.something and was included in iscan package.
On arch the only way to get it was to install Utsushi, which, I didn’t realize at the time was an entire front end, plus it was gui based.
The arch wiki was confusing because it mentions an imagescan (Utsushi) package without any context about what it actually was.
The image scan v3 driver is separate from the Utsushi front end, but included.
And I think that it is extreme overkill, since I use sane’s command line tools, plus I don’t have a gui in the first place, for my scanning needs. Namely, scanimage, lol.