Home | News | Download | Packages | Forum | Wiki | Github

Reimagining Installation Process


(James Aanderson) #41

As I remember it I thought it was very good. My only SNAFU was that I need to wipe the drive boot block from the CLI, which wasn’t an option from the GUI.

But generally, the curses installer is very much like the old slackware installer, which was also pretty good.

Whatever updates are made, please give consideration to the minimal hardware user. I don’t know if the void boot disk has a tty console turned up by default like Arch does, but it is a good feature for commercial users. I’ve installed arch from a 9 pin crossover cable, and it wasn’t fun. But it scales, sorta. Unfortunately, Arch itself doesn’t scale all that well. So…

Personally I think the best way would be to make the configurator web based. A web page on VOID print out XML in a text file, that could then be cut and pasted to TTY, or sneaker netted onto the host.

Generally I prefer to do the initial configuration and the firewall setup over a TTY, and only then plug in the network interface and install the rest of the features.

I have nothing against GUI’s, I just never have enough plugs or desk space for the extra monitors. So the best of both worlds would be a cut and pastable XML file produced from a Web GUI.

As long as the configuration file is human readable, I think this is a polite solution that most people would accept. It doesn’t have to do everything, just all the trivial stuff. The users can then do the rest by hand, or append their own XML in order to cascade the installation process in a scalable and secure way.

The biggest issue with installers, has been the same for decades. They either don’t scale, or they are insecure. And lets face it, there is enough work there by itself.

(Linux user since kernel 0.98)


#43

Wait, really? Everything I’ve ever read; every README, wiki, HOWTO, and forum post (all of them!) has always used # to represent a root shell and $ to represent a non-root shell.

If you open up a non-root shell on any Linux distro, I can almost guarantee you that your prompt will contain $. Likewise if you are root, your prompt will be #. This is true on my Void system ay least, and I have not modified my PS1 or changed my prompt in any way.

Is this really not the case? Regardless, it seems to be that the convention is very well-accepted and very widely used. Why not conform to it? Seems like it would have alleviated confusion in this case :S


(seth) #44

i can’t speak for the maintainers but i am positive they are following the #/$ convention. any edits to the wiki that I have made also follow this convention (please no sudo in the wiki!).
in fact, it likely has almost zero to do with void maintainers because these conventions are followed (say it with me now) Upstream!


(Paul B.) #45

Interesting no one mentioned the issue in the attached screenshot. When I initially installed Void i found the messages to be disturbing because i wanted to preserve my data. I did figure out the install settings toggle a boolean value when determining whether to format so i felt ok with it but some may not know this.

The only new file system i chose was /dev/sda2


#46

Please don’t force choices on the user. And don’t force me to use sudo (it should be an optional package). This is the reason i’m using Void and it’s the reason i was a Gentoo user for 10 years.

The only thing the installer needs is fixing (or removing) the UserAccount section that does not work.


#47

It didn’t work for you? weird…
Why not open a new topic, to demonstrate how broken the ‘UserAccount section’ is, and to seek solutions? Your experience with Gentoo should help! :sweat_smile:


#48

It didn’t created the account, so i needed to do it after by hand. No big deal.
I read somewhere here that it’s been an issue for some time.

I don’t think being a Gentoo user makes me an expert. It’s a lot similar to Void, the compiling stuff is done automatically by portage. I know the same or less than everyone here.


#49

oh sorry, I misinterpreted!
Yes, some users reported problems with the UserAccount creation…
However [ for some “unknown reason” ] the installer worked flawlessly for other people. :performing_arts:


#50

@sevendogs The message given there is slightly misleading, the first time I saw it, I re-ran the installer to double check my partition settings. Satisfied, I decided to plow ahead. I did not lose any data.

@GrandOrbiter The account creation section has worked fine for me on a number of occasions


(Paul B.) #51

I understood the message but it should not say that new file systems are going to be created on every device. The dialog should check which devices/partitions the user requested be formatted and only put the label “new file system” next to those devices/partitions, not all of them. The installer already knows this because the settings show a “1” for devices to be formatted and a “0” for those to be left intact.

Just an improvement suggestion, thats all.


#52

I have encoutered problems with creating an account before and found that there’s an open issue at the void-mklive repo about it:


#53

It didn’t work for me with both musl and glibc versions at home and with glibc version at work.


#54

Ah, perhaps this calls for some maintenance on the installer. Sanitizing input to avoid invalid account names should be easy enough, especially if it’s just UPPERCASE usernames that provoke the bug.


(Erin) #55

On two installs the user has worked correctly on glibc EFI/LVM for me. Username was lowercase on both machines, two laptops; one AMD and one a x230 Thinkpad.