Home | News | Download | Packages | Forum | Wiki | Github

Possible OpenGL bug plaguing my netbook


(kenny_w) #1

Hey guys, so I came to Void Linux because I wanted to see if game emulators would work properly or not.
This happens to me on Debian too. After playing for a few minutes, the game will suddenly and randomly become very laggy, to the point where its unplayable.

Its a Dell Inspiron Mini 10v (1011) intel atom N270 32-bit 10" netbook.
The video card is an intel i915 945GME x86/MMX/SSE2
it has 2GB of DDR2 RAM. Its a bit of an older laptop but it works good… I don’t know where this bug came from, but one day my laptop started doing this when I play emulator games. I’m not playing games that take much resources - its like GameBoy emulators, Nintendo64, Super Nintendo, old Sega emulators, etc…

What should I do? Should I try BSD??? I don’t understand why it would do this… I just want my netbook to play games and watch videos while I’m on the bus or waiting in the doctors office…

It goes from roughly 43.000ish+ UI/S all the way down to
15-17.000 UI/S
And the sound starts to lag as well too.
Something definitely isn’t right, but I can’t figure it out… What could this be?

It would at least seem that I need to reboot my PC to make it go away, then I can re-open the emulator & its fine again for maybe 10-15ish minutes…

At one point in time I had no problems at all running emulator games… I used to run Fedora 25 & Debian Sid on this netbook no problem! So what has changed?!

I’m running some tests on the 4.9 LTS kernel to see if it goes all messed up on 4.9 too, I have a funny suspicion that its got something to do with the kernel, I’m testing this right now as I’m typing this.


(Masato the Empty) #2

Well about the only emulator I’ve used since switching to Void is mednafen (used to use pcsxr for PSX games, but I’ve found mednafen working much better)

Using a desktop running an ivy bridge (3770) with the iGPU (i915 driver) and I haven’t had any video problems. On the other hand, laptop chipsets have all sorts of various optimization bits thrown in and one piece of hardware or another can mess up on some kernel configs.

That’s just to say it should work but hardware varies, especially in the laptop realm. Void uses the same kernel code as everyone else, except they don’t patch the hell out of it (wouldn’t be much point on a rolling-release…)

So while it doesn’t exactly rule out buggy (or perhaps better put: quirky hardware) I suspect you’re on the right track in suspecting kernel builds.

If you don’t have a kernel where it worked before, it might be rather difficult to figure out where things broke, though if you find it is good in LTS, then you can comb through kernel commit history, probably starting at the next kernel series. Not fun unless you’re into that, but not necessarily so bad if you have a good idea as to what types of changes to look for. The usual suspects would be drm and i915.


(kenny_w) #3

DRM? How can I check out this ‘DRM’ you speak of?

Man its so weird! Its like… it will play fine for 10 or 15 minutes but then SUDDENLY OUT OF NOWHERE MASSIVE LAG!

Can you try mupen64plus & tell me what happens? I play Mario Kart 64 & Legend of Zelda Ocarina of Time, also Kirby Crystal Shards 64. I just don’t understand what could be causing this awful lag…

This old netbook is so great, its got a new 120GB SSD harddrive & new RTL8821ae 5G+Bluetooth WiFi card, its got a 4+ hour battery, 10 inch 1024x600 screen, it boots up in under 10 seconds & it actually runs really well for an intel Atom N270 32-bit 1.6GHz, its a 2008-09 model I think. I got it for free & put $40 into buying a new charger port & charger, I’ve put so many hours of work into this thing, it makes me very sad that it bugs out on me when I try to play emulator games that take up very little resources :frowning:

I’ve installed Parabola OpenRC Linux alongside Void Linux & allowed Void Linux to control the GRUB because I’m using the archlinux32 4.9 kernel since parabola’s LTS is now 4.14, it would seem the 4.9 kernel acts very strange on Void Linux when I try to play emulator games, like for example the controller config goes all wonky & it doesn’t work properly on Void 4.9… The kernel shouldn’t have anything to do with mupen64plus’s controller config… If I set it to OpenGL 1.1 it will be a bit lagish but it doesn’t go into ‘massive lag mode’, also in Ocarina of Time, the colours go weird - Link will be white instead of green & the paths on the ground will be white also… Some things are red too which is weird. I’m REALLY hoping the results will be different on Parabola 4.9.

Also in regards to patched kernels for rolling releases, Arch Linux has the linux-ck kernel which works quite well! Would be nice if Con Kolivas started a Void Linux repo for linux-ck for Void. I use the linux-ck kernel on my desktops & it works wonders! However, I am interested in Void’s reasoning against having patched kernels. Is it something Team Void doesn’t want to do themselves because of time or is it something they’re strongly against?


(Masato the Empty) #4

I always hear the Void folks say the policy is build-and-ship. I think the size of the core team vs the size of the distro is not insignificant to the reasoning, even if it’s only one facet. I do suspect that nobody wants to maintain an alternate branch of the kernel.

But my experience is with debian, and they frequently have a lot of patches. Some are bugfix/backpatches from development branches, or at least more current ones (even when I used Sid I don’t recall the kernel being updated every time kernel.org incremented the version).

DRM - I’m referring to what you’d look for in the kernel changelogs, though they might actually read “dri” (direct rendering manager, direct rendering infrastructure). Been a few months since I’ve had reason to look for that kind of stuff.

I wonder, when you get this issue, can you check dmesg for MCEs? Especially ones related to thermal threshold. Also, if you don’t have lm-sensors installed and configured, I highly recommend it. You can run sensors to show temps. The sudden lagginess reminds me of my old P4 when it got too much dust built up and started throttling (nice thick carpet of dust stuck between the fan and heat sink…)

Now just to make sure I’ve got this down, did I read you right when I think you indicated that you haven’t always had this issue? And you were using Void before this issue started?

EDIT/ADDENDUM:
Also, the color issue when you change gl version… you should match the GLX version of your video driver. run glxinfo (package glxinfo) and that will tell you about the loaded GL driverss.


#5

See this comment


#6

:male_detective: #11703


@kenny_w try to find something in the log:

$ sudo dmesg |grep drm


(kenny_w) #7

I know that’s why I’m saying someone else should maintain it :stuck_out_tongue: like the linux-ck kernel lol
Also yes I’ve checked the logs & doesn’t seem like there’s anything there… It would appear my problem starts with kernels 4.12+, it would seem kernels 4.9 - 4.11 are fine… Very strange in my opinion. It works like this on all distros it would appear.


(Masato the Empty) #8

Well, it sounds like you’ve narrowed the issue down to kernel version 4.12. If you have tried the latest 4.11 (4.11.12) and still no problem, then you can start looking at kernel changelogs starting with 4.12.1 to see if any of the drm/i915-relaed changes look like they might affect you. Actually, looks like4.12.4 started seeing updates in the drm/i915 code. Otherwise, start at the version of 4.11 following the last known working one.


(Masato the Empty) #9

Also note that since ths is a bit older and rather low-end hardware, you might not necessarily benefit from running newer kernels, so running the last working LTS kernel might be a good option.

Since you seem to find breakage in 4.12, you may do well to stick with 4.9 until (and beyond) its EOL (I don’t know when that will be). Sticking with 4.9 over 4.10 or 4.11 would be because 4.9 will continue getting bug/security fixes while the later series will not.

Something to consider if you’re otherwise unable to get to the bottom of the issue.


#10

who “someone else” ?? I don’t understand.


#11

January 2019, see kernel.org/releases.


(kenny_w) #12

Would you guys think I was crazy if I said I thought it might have something to do with the new I/O schedulers that come with kernels 4.12+ ?


(Masato the Empty) #13

Can’t say I’ve read up enough on them to have an opinion. But unless the old scheduler is not available, you should be able to test that idea by booting with a different scheduler. (check kernel docs and/or intarwebs for info on changing/tweaking i/o schedulers).

A side note… might depend on the different hardware (since our software environments are both Void) but for Zelda: OoT I found the rice plugin doesn’t give great results (messed up menu screens); running with --gfx mupen64plus-video-glide64mk2 works much better.

Also, no slowdowns noticed (but I’ve got significantly more resouces on my desktop… though I still run on a mechanical HDD)


(kenny_w) #14

Upon further testing I have determined that this bug still exists when I use kernel 4.9 & regardless of I/O scheduler. I’m really not sure what could be causing this “bug”! I can’t seem to figure it out… I’m running a Dell Inspiron Mini 1011 (10v), its in great condition for an old netbook & it works great for playing videos & games, now not-so-much with games but still plays videos well. The games I’m playing are really low-end so they SHOULD work fine, but they don’t, and that’s got something to do with the drivers or god only knows what…

After 10-20 minutes playing it’ll start to lag like mad. I’ve never seen anything like this. I’m starting to notice some things, like when I run another process while the game is open, the game will just start to lag like mad & won’t stop, I think some other process running is messing it up but I am just not sure…

Also, the RICE video works just fine for me. Never noticed any messed up menus. I get this bug when trying to play gameboy too. I’m starting to think my only way forward is buying a new 10" netbook. I really love having a small laptop that I can carry around with me, can’t do without one.


#15

@kenny_w is your BIOS up to date? looking at their website, I think the latest release is this one?