Home | News | Download | Packages | Forum | Wiki | Github

Owncloudclient fails to paint window under i3


(oliver) #1

This almost has me pulling my hair out

Some time ago (not sure when) owncloudclient stopped working. And by ‘stopped working’ I mean I can launch it but the window is borderless and blank. The only way I know it’s there is because the space behind the window stops updating. Imagine a terminal of scrolling text with a frozen window shaped block in the middle. I also get a blank icon in the systray that is not clickable. I only know it’s there because the other icons shift left when I run it and then back to the right when I kill it.

First I tried wiping out my owncloud conf files with no change in behaviour… then I tried under a new user account and under a different WM. I’ve tried deleting it along with all the dependencies (quite a few QT apps) - nothing worked.

Last night I installed a virtualbox MUSL Void with i3 and owncloudclient runs perfectly.

So I know it’s something on my system but not related to a user account.

What else can I do? I tried ‘xbps-pkgdb -a’ but it didn’t return anything useful (something about upowerd0 which I didn’t even know I had installed)

Is there another way to verify all the installed apps?

Update - problem is related to Xorg. I installed sway along with xorg-server-xwayland and all is good.
If I go back to i3 over Xorg it fails again

I’m liking Sway though so I think I’ll stick with it


(Michael Aldridge) #2

I suspect the problem you are encountering is actually to do with i3 and the fact that many applications do not correctly process the window geometry struct that is passed back by i3. Despite it being part of the X standard for decades now, it still isn’t done right in Qt and a few other popular frameworks.

I’d try this in openbox and see if the same problem manifests there. As to why it works in sway, that is likely to do with the way that sway and the X shims in wayland provide data back to the client.


#3

@oliver could you try with turned off composite in xorg?

Create file in /etc/X11/xorg.conf.d/20-composite.conf with this inside:

Section "Extensions"
    Option "Composite" "off"
EndSection

(oliver) #4

I tried it in openbox with no change in behaviour. I had previously tried in Awesome (and owncloundclient does work in a freshly installed virtualbox i3 setup)


(oliver) #5

Thanks for the idea - no change though. Still only works in sway


(Michael Aldridge) #6

Odd, I’m not too familiar with owncloud but I suspect this has to be something with some X extensions you have loaded that aren’t loaded on the live disk since you say it works there.