Home | News | Download | Packages | Forum | Wiki | Github

Notepadqq segfaults


(Xander Hoogendoorn) #1

Hello.

Today I’ve tried installing notepadqq and while installing it was successful, running it was not. I got a segfault and I am not certain how to proceed from this point as notepadqq isn’t particularly talkative.
Any suggestions?

I’m on musl, so that may be explaining the problem. But I’m not going to give up so easily.


(Jacob Moen) #2

Are you running it from the shell (WM) or from a console/terminal/prompt ?

If the first, try in a command prompt as it might spit out the error(s)


(Jacob Moen) #3

Could it be related to this ? -> https://github.com/notepadqq/notepadqq/issues/460

Downgrading qt5-webkit 5.9 -> 5.8 has stopped the seg fault in the test file. A rebuild of qt5-webkit-5.9 did not fix the problem. notepadqq must have the same version to build but I can run with qt5-webkit at the lower version.


(Xander Hoogendoorn) #4

Well, I tried running from the console.
I noticed the segfaults go away when you provide it with the directories the script is looking for, but then it just sits there and does nothing.
No output at all.
-v just outputs some version information.

xbps-query gave me this:

architecture: x86_64-musl
build-date: 2017-08-31 11:48 GMT
filename-sha256: 6c14a0b52fedf80fab88a0e68343d878bf782bce9765ffc6b13652be5e8ee316
filename-size: 1074KB
homepage: http://notepadqq.altervista.org/s/
install-date: 2017-09-06 17:32 CEST
install-script: 960B
installed_size: 5062KB
license: GPL-3
maintainer: cr6git <quark6@protonmail.com>
metafile-sha256: 8b7fd3ca536b608bf7803eec0e46979791dee8ee584904794b8697874b95e570
pkgver: notepadqq-1.0.1_1
remove-script: 958B
repository: https://repo.voidlinux.eu/current/musl
shlib-requires:
	libQt5WebKitWidgets.so.5
	libQt5PrintSupport.so.5
	libQt5Widgets.so.5
	libQt5WebKit.so.5
	libQt5Gui.so.5
	libQt5Network.so.5
	libQt5Core.so.5
	libstdc++.so.6
	libgcc_s.so.1
	libc.so
short_desc: Text editor for developers
source-revisions: notepadqq:ec7716d1f1
state: installed

I’d like to add that qt5-webkit is of version 5.8.0_4


(Jacob Moen) #5

It works on my machine, and I think it’s safe to say our two machines are practically identical except one crucial difference: you are using musl and I am using libc.

Could be an obscure bug related to that?