Home | News | Download | Packages | Forum | Wiki | Github

No space on device


#1

Started fresh with new git hub fork, new binary bootstrap
Tried to do nothing but build audit audit-devel in master branch.
xnew audit audit-devel

Build apparently worked, except:
=> WARNING: audit-2.7.1_1: libaudit.so.1 not found in common/shlibs!
=> WARNING: audit-2.7.1_1: libauparse.so.0 not found in common/shlibs!
So that needs fixing.

Registering audit-2.7.1_1.i686.xbps into /host/binpkgs …
index: added audit-2.7.1_1' (i686). index: 2 packages registered. => Registering audit-32bit-2.7.1_1.x86_64.xbps into /host/binpkgs/multilib ... index: addedaudit-32bit-2.7.1_1’ (x86_64).
index: 2 packages registered.
=> audit-2.7.1_1: removing autodeps, please wait…

I had something similar before which was why I started completely fresh, then it failed before geting this far and my browser crashed mysteriously while it was hanging, and I couldn’t start it again or any other browser until I stopped xbps-src with ctrl-c.
Then it hangs here. Trying to save a file in nano, it failed saying no space left on device.

$ sudo vkpurge rm all
Password:
Removing kernel 4.9.4_1 files …
Removing /boot/config-4.9.4_1…
Removing /boot/System.map-4.9.4_1…
Removing /boot/vmlinuz-4.9.4_1…
Removing /lib/modules/4.9.4_1…
rm: cannot remove ‘/lib/modules/4.9.4_1/kernel/drivers/staging/rtl8192u/r8192u_usb.ko.gz’: No space left on device
rm: cannot remove ‘/lib/modules/4.9.4_1/kernel/drivers/staging/fwserial/firewire-serial.ko.gz’: No space left on device
rm: cannot remove ‘/lib/modules/4.9.4_1/kernel/drivers/staging/comedi/drivers/cb_pcidas64.ko.gz’: No space left on device
rm: cannot remove ‘/lib/modules/4.9.4_1/kernel/drivers/staging/comedi/drivers/me_daq.ko.gz’: No space left on device
rm: cannot remove ‘/lib/modules/4.9.4_1/kernel/drivers/staging/comedi/drivers/s626.ko.gz’: No space left on device
rm: cannot remove ‘/lib/modules/4.9.4_1/kernel/drivers/staging/comedi/drivers/comedi_test.ko.gz’: No space left on device
rm: cannot remove ‘/lib/modules/4.9.4_1/kernel/drivers/staging/comedi/drivers/ni_tiocmd.ko.gz’: No space left on device
rm: cannot remove ‘/lib/modules/4.9.4_1/kernel/drivers/staging/comedi/drivers/adv_pci1724.ko.gz’: No space left on device
rm: cannot remove ‘/lib/modules/4.9.4_1/kernel/drivers/staging/comedi/drivers/cb_pcimdas.ko.gz’: No space left on device
rm: cannot remove ‘/lib/modules/4.9.4_1/kernel/drivers/staging/comedi/drivers/contec_pci_dio.ko.gz’: No space left on device

Hit ctrl-c on xbps-src
^[[B^C=> audit: removing files from destdir…
=> audit: removing 32bit files from destdir…
=> audit-devel: removing files from destdir…
=> audit-devel: removing 32bit files from destdir…
=> ERROR: xbps-src: a failure has ocurred! exiting…

and rm works again.
This is on BTRFS with about 15GB free. Does xbps-src use all that? Or is it filling up swap and RAM, but I could still do other things except HDD ops fine, nothing’s running slow like when things are swapping. I built the nano package the other day OK but that is simpler. And I built this same package last year on EXT4 OK on the same hardware, with the same template at an earlier version.

# Template file for 'audit'
pkgname=audit
version=2.7.1
revision=1
build_style=gnu-configure
configure_args="
        --prefix=/usr
        --sbindir=/usr/bin
        --sysconfdir=/etc
        --libexecdir=/usr/lib/audit
        --with-python=yes
        --enable-gssapi-krb5=yes
        --enable-systemd=no
        --with-libcap-ng=yes
        --disable-zos-remote
        --enable-static=yes"
conf_files="
        /etc/libaudit.conf
        /etc/audit/auditd.conf
        /etc/audisp/audispd.conf
        /etc/audisp/audisp-remote.conf
        /etc/audisp/plugins.d/af_unix.conf
        /etc/audisp/plugins.d/au-remote.conf
        /etc/audisp/plugins.d/syslog.conf"
makedepends="swig linux-headers python python-devel libcap-ng libcap-ng-devel"
depends="mit-krb5 libcap-ng"
short_desc="Userspace components of the audit framework"
maintainer="zqqw <u7181-maintain@yahoo.co.uk>"
license="GPL-2"
homepage="https://people.redhat.com/sgrubb/audit"
distfiles="${homepage}/${pkgname}-${version}.tar.gz"
checksum="0441790794fd9375dbca598fa0ffb46c57ff37b3a24b94ffec0bbee3215cca09"

audit-devel_package() {
        depends="${sourcepkg}>=${version}_${revision}"
        short_desc+=" - development files"
        pkg_install() {
                vmove usr/share/man/man3
                vmove usr/include
                vmove usr/lib/pkgconfig
                vmove "usr/lib/*.a"
                vmove "usr/lib/*.so"
                vsconf contrib/avc_snap
                vsconf contrib/skeleton.c
                vmkdir usr/share/examples/${pkgname}/plugin
                vinstall contrib/plugin/Makefile 0644 usr/share/examples/${pkgname}/plugin
                vinstall contrib/plugin/audisp-example.c 0644 usr/share/examples/${pkgname}/plugin
                vinstall contrib/plugin/audisp-example.conf 0644 usr/share/examples/${pkgname}/plugin
        }
}

An apparently simple task confounded by weirdness!


(Benjamin) #2

The git repo is pretty huge with lots of commits… there might be another issue going on right now but the main one I can think of is that cloning the entire repo filled up your drive. I would try removing the git dir and recloning it with the args --depth=1 to use less space. (only downloads the last commit changing the file and no branchs are downloaded)


#3

Thanks for the suggestion, I’ve now deleted a whole bunch of stuff, 2 or 3 GB including another failed repo pull - this was only about 100 and something GB compressed so wasn’t that big even for my little HDD! But the problem reoccurs, I think it is one of those BTRFS no space left problems that seem to happen. Perhaps it is related to the chroot.
While xbps-src was hanging and the no space errors were occurring e.g. in Nano: Error writing xbps-src.txt: No space left on device:

$  sudo btrfs fi df /
Data, single: total=12.01GiB, used=8.00GiB
System, DUP: total=8.00MiB, used=16.00KiB
Metadata, DUP: total=1.00GiB, used=277.28MiB
GlobalReserve, single: total=28.16MiB, used=9.67MiB
$ sudo btrfs fi show
Label: none  uuid: 7106672b-4d04-4a8e-9f78-51f9be667da8
        Total devices 1 FS bytes used 8.28GiB
        devid    1 size 26.39GiB used 14.02GiB path /dev/sda2

I think I’ll have to go write a bug report :helicopter: