Home | News | Download | Packages | Forum | Wiki | Github

New user to Void Linux, tips cheatsheets


(kenny_w) #1

Hi guys. I started using Void Linux the other day on my i386 netbook, I ran into some issues with getting QTSIXA to work though & I have a drivers problem that makes kernel 4.13 not work, but 4.12 works OK… So I’m back on SparkyLinux for now until I can solve two issues I’ve posted below then I’ll make my way back to Void Linux.

I’m looking for any kind of helpful cheat-sheets to compare Void Linux commands to Debian’s APT/Fedora’s DNF/Arch’s pacman, as well as cheat-sheets with Runit to OpenRC/SysVinit/SystemD comparisons…

I also have some other questions like, what package is build-essential’s equivalent? What about qtbase5-private-dev or qtbase5-dev-tools, qttools5-dev-tools, pyqt5-dev-tools, pyqt4-dev-tools, etc.

Is there a build-dep command? What commands would you wish you’d of known sooner?

And lastly, does anyone have any good tips for people just starting out with Void Linux? Anything you wish you’d of known sooner? All replies are greatly appreciated, thank you very much for taking your time to help me out!

in case anyone is curious about the other issues I mentioned,



#2

Void linux provides many different kernel versions.
See xbps-query -Rs linux.

There is this one for xbps https://wiki.voidlinux.eu/Rosetta_stone, but in general I would suggest you to read the wiki and man pages for xbps and runit, because they are different implementations from their counterparts in other distributions which have some features that others lack, just translating specific things instead of learning how to use it the right way will hide those features form you.

The base-devel meta package is similiar to build-essentials from debian.
Development packages have the -devel suffix in Void.
xbps-query -Rs pkgname should show them.


#3

Same, have one old 32 bit laptop. As a workaround you can manually pick previous kernel version at boot in advanced menu. There are commands for kernel with ‘hold’ keyword, but don’t know exact command.
The only commands related to kernel in my cheat sheet are these:

xbps-pkgdb -m hold linux4.9 <- to avoid updating the 4.9 kernel from to current minor versions e.g. 4.9.1 to 4.9.2.
vkpurge list <- get the list of old kernels
vkpurge all <- vkpurge deletes all /old/ versions of Kernels, so you will always keep 1 version of each kernel around

Otherwise here is my cheat sheet:



xbps-install -S <- update the system - To synchronize your repository databases and update your system to the most recent packages, + their dependencies
xbps-install -u

## say you have some problem with way too old library say library is: "glibc"
## to solve this you should first install/update that library first:

xbps-install -Su glibc <- install/update trouble making library first then update the system
xbps-install -S xfce4 xorg xterm <- install single or several packages with their dependencies
xbps-install -Sf pkg-1.0_1 <- to reinstall or downgrade specific package
sudo xbps-install -Sf os-prober-1.74_1 <- to downgrade os-prober to version 1.74_1

## xbps-query doesn't need root permissions

xbps-query -s brother <- search only localy installed packages
xbps-query -Rs brother <- to search in the repositories
xbps-query -Rs “string” <- search for string
xbps-query -f package name <- to check which files were installed by any particular package
xbps-query -X packagename <- to find out what packages depend on a package called “packagename” with
xbps-remove package_name <- to remove a single package, leaving all of its dependencies installed
xbps-remove -R package_name <- to remove a single package and all of its dependencies that are not required by other packages

xbps-query -l <- listing installed packages
xbps-query -L <- listing registered repositories
xbps-query [-R] pkg <- showing information for a package
xbps-query [-R] -f pkg <- showing the files list for a package
xbps-query [-R] -x pkg <- showing the required dependencies for a package
xbps-query [-R] -X pkg <- showing the reverse dependencies for a package (packages that depend on it)
xbps-query -m <- showing packages that were installed manually
xbps-query --regex -Rs “text editor” <- you can also use xbps-query to search the packages

xbps-remove pkg <- removing a single package
xbps-remove -R pkg <- removing a single package and recursively all packages that were installed as dependencies
xbps-remove -O <- cdmsg.txtleaning up the cache directory
xbps-remove -o <- removing all package orphans
xbps-remove -Oo <- removing all package orphans and clean the cache directory
xbps-remove -f python3.4-tkinter <- force remove “python3.4-tkinter”


(Scott Robbins) #4

I came across the troubleshooters guide to void, which, although a couple of years old, seems to document a few things that I didn’t see elsewhere.
http://www.troubleshooters.com/linux/void/voidtips.htm

There are definite out of date things, such as setting up xombrero, which, whether or not still in Void repos, doesn’t seem to be developed anymore. However, it was still a good and useful read.


#5

Yes, install guide from this site helped me installing Void. Good site!


(Scott Robbins) #6

And, just to add, in case new users come across this thread and check that site, they talk about the freenode #xbps channel. The channel is now #voidlinux.


#7

And I’m working on a faq site like the one from OpenBSD, its still not complete if someone wants to help https://github.com/voidlinux/voidlinux.github.com/ has the source and pull requests are welcome.
https://www.voidlinux.eu/faq/


(Scott Robbins) #8

I haven’t yet learned enough about Void’s idiosyncracies to offer to contribute, but that’s a great idea. Things like manual installation and other things that you seem to be working on will be a great help.


(Bearz) #9

I like the idea of the FAQ. Is it meant to replace a section of the wiki though? It does seem like there is a lot of redundant info.

Regardless, I will try to contribute to it when I get a chance.


(notpod) #10

That troubleshooters guide while out of date really helped a LOT! That should be taken, reworked and melded into the wiki and or FAQ.


(kenny_w) #11

if any of you could please take a look at the two other forum threads I linked at the top, that’d be awesome. Having some troubles with some deal-breaking software that I need to work in order to use void.


(kenny_w) #12

Hey dude I might have a possible fix if you get the same problem as me with kernel 4.13+

Comment this line out in grub, OR if its not in GRUB then you just put “text” instead of keep.
GRUB_GFXPAYLOAD_LINUX=“keep”

I had a video driver bug with GRUB, doing this made the video driver bug go away completely! Now I can see my screen once booted up! It cut off 4/5th’s of my screen after booting past GRUB, now I have my entire screen back :smiley: