Home | News | Download | Packages | Forum | Wiki | Github

Mounting NFS-share using autofs

(rakor) #1

Hi there,

I’d like to mount my nfs-shares using autofs. So I installed it, checkes the config (there is the needed line “/net -hosts” already active) and started the service.

Poorly it does not work I have the directory /net, but I can’t reach my shares there. I used autofs on other systems without issue.

I can also mount the shares manually, so nfs is working. (rpcbind is started also)


See the wiki #Autofs.

(rakor) #3

Thanks for your hint. I read the wiki-article but it doesn’t help me cause it does not contain information about mounting nfs-shares. AFAIK the line “/net -hosts” should do the job for nfs shares. Thats what the internet, the manpage and my experience on other system says… But I doesn’t work. :frowning:


I got it working after changing these lines in /etc/autofs/auto.master




Enable autofs
Exports are mounted at

ls  /net/i.p. address

(rakor) #5

Hey thanks a lot. Exactly doing your change did not work for me, but it gave me a hint. I commented the two lines, and now it’s running. Seems it has overwritten something.