Home | News | Download | Packages | Forum | Wiki | Github

Mklive


#21

:worried: Gosh ! How it could still be possible nowadays ?

I mean you are in high-level technical studies, you learn how to use sophisticated tools… So why your university & teachers don’t use a sophisticated OS (like Linux) on their computers ?

I mean your university & teachers should aim at excellence in all areas (I suppose), so why they don’t choose the best OS for their machines ?

Even if your university is not focused in Computer Science you should try to convince them to throw Windows away, just my opinion… :smirk:


(Saleem Khan Marwat) #22

so mklive can create a backup ISO of my custom made installed Void Linux into a bootable and installable live ISO to be written to a USB and use to do install rather downloading and installing a barebone ISO from server and doing all the tweaks/customization from scratch?


(Saleem Khan Marwat) #23

Hello @Duncaen,

I followed these steps to install mklive but I am getting errors

https://nopaste.me/view/5ae03aa3

what am i doing wrongly?


#24

:worried: I don’t see any error in your log…

You just used ./mklive.sh -h to see the help… What’s your issue ?


(Saleem Khan Marwat) #25

@cr6
I think you are right.
But I am wondering how/what command will make an ISO of my installed Void Linux?


(Saleem Khan Marwat) #26

@cr6

https://groups.google.com/forum/#!topic/voidlinux/CfxWP6_uaVU

I am looking for a function like this from mklive


#27

@saleem You should look on the wiki: Void on USB


(Masato the Empty) #28

I don’t think mklive will do everything you want here, but it can be part of the solution as you can use it to keep an up-to-date install medium. You’d need another method for backing up configuration and user data.

This way, your restoration strategy would consist of installing the OS from your most recent install medium, then restoring your backed-up configs and user data. This is the method used by some commercial backup/restoration solutions I’ve worked with in the past.

You’ll need to specify the packages beyond base that you want, but if it’s just all of your presently-installed packages, you could just use xbps-query to generate a list of all manual packages on your system. Something like this:
-p "$(xbps-query -ms '*')"
This will print the package and version numbers. I don’t know if this is a problem, but if it is, then you’ll want to edit those out. something like this should do the trick.
-p "$(xbps-query -ms '*' | sed 's/-[0-9].*//')"


#29

I’ve been very busy with work and thus haven’t even experimented with it yet. Whenever I do though I’ll shoot you a DM.


#30

Good day, everyone.

I have downloaded and extracted the .zip archive and ran make.

Everything seems good, except that the resulting .iso is always 50M and seems to be missing the rootfs. (I get the error while booting). I use the following command to generate the .iso:

./mklive.sh -a x86_64 -k colemak -S 256 -p "xfce4 connman connman-gtk connman-ui rxvt-unicode zsh neovim firefox wget hdparm"

Here’s the complete log of the process.

What am I doing wrong?


#31

Which .zip archive are you talking about ? :thinking:

You just have to clone the void-mklive repos:

$ git clone https://github.com/voidlinux/void-mklive


(David) #32

Github offers repo downloads as .zip archives as an alternative to cloning.


#33

@tactica is correct, I downloaded the .zip from github.

Just tried with cloning and nothing changed. Still 50M


#34

@eichhorn For your information, on my computer I have no problem to build a new ISO, by using your custom command line:

./mklive.sh -a x86_64 -k colemak -S 256 -p "xfce4 connman connman-gtk connman-ui rxvt-unicode zsh neovim firefox wget hdparm"

For me it works.
I really don’t know why you have this problem, sorry. :confused:


#35

Thanks for checking. Apparently, something must be wrong with my machine, since exactly the same comand on the other computer gives me the proper 458M image.


#36
[8/9] Generating squashfs image (xz) from rootfs...
mount: /tmp/void-mklive-master/tmp.Pv55QVZK6R/tmp-rootfs: wrong fs type, bad option, bad superblock on /dev/loop0, missing codepage or helper program, or other error.
umount: /tmp/void-mklive-master/tmp.Pv55QVZK6R/tmp-rootfs: not mounted.

#37

Didn’t notice, thanks!

I suppose that fs-type and options are set by the script itself.
Helper program is likely to be qemu-user-static mentioned on github, but I have that installed also.

That leaves me with bad superblock or missing codepage. May it have something to do with the kernel? That’s the main difference between the two machines I can think of.