Home | News | Download | Packages | Forum | Wiki | Github

Local Install: Several video issues


(Bruno de Souza Lino) #1

Hello.

This is perhaps the second time I’m trying to install the musl XFCE build of Void, but I’m running into several issues that seem to have no solution:

  • Both the live image and the fresh install freeze before loading the display manager, unless ‘nomodeset’ is added to the boot parameters.

  • I have a monitor where I have to force the native resolution due to a broken EDID. You usually do that using ‘gtf’ to get the timings for that resolution and refresh rate, then xrandr to add the new resolution and switch to it. Problem is, neither of those two commands are found at all by bash and they don’t seem to exist at all on either the repo or the installed system.

Before making this post, I spent about 30 minutes looking for similar issues other people might have in the forums and other places, but all the other users with issues seem to have xrandr working, which I don’t, so I can’t use their solutions or go from their solutions as a starting point.

What to do? Should I install Void from zero instead of Local Install? I tried before, but my wifi card refuses to work after the installation is done.

My Current Hardware:

  • Pentium D 920
  • 2 GB RAM
  • Radeon HD5450 1 GB

This setup works fine with an Arch installation I have, except for some microphone issues, but I’m not using the mic anyways, so that’s a non-issue.


(Erin) #2

You could ask the xrandr maintainer [xtraeme] why there us no i686 musl package.

For gft, if you have the “gtf” information, that can be installed in an xorg.conf file so doesn’t need to be rerun each boot. the gtf man page explains all for example here


(Bruno de Souza Lino) #3

I’m using the x64 build of void.

As per the gtf timings, I may have them in a shell script somewhere, but I wouldn’t bet on that. There is a libXrandr package in the repos, but installing it doesn’t seem to do anything.

Even the other utility that could give you said timings (cvt) doesn’t seem to be present either.


(Erin) #4

xrandr and lxrandr are both in the repository for x86_64 musl. https://www.voidlinux.eu/packages/ is a useful place to check packages.


#5

Something is wrong. Look here:

[pin@awesomevoidmusl ~]$ xbps-query -Rs xrandr
[-] arandr-0.1.9_1          Graphical frontend for XRandR
[*] libXrandr-1.5.1_1       X RandR Library from X.org
[-] libXrandr-devel-1.5.1_1 X RandR Library from X.org - development files
[-] lxrandr-0.3.1_1         LXDE Monitor configuration tool
[*] xrandr-1.5.0_1          Primitive command line interface to RandR extension
[-] zrandr-0.2.2_1          Simple Qt5 front end for xrandr
[-] libXrandr-dbg-1.5.1_1   X RandR Library from X.org (debug files)
[-] lxrandr-dbg-0.3.1_1     LXDE Monitor configuration tool (debug files)
[*] xrandr-dbg-1.5.0_1      Primitive command line interface to RandR extension (d...
[-] zrandr-dbg-0.2.2_1      Simple Qt5 front end for xrandr (debug files)

As you can see I’m on void_musl. Using Awesome wm.

EDIT: Espero que isso se resolva!


#6

In which linux distribution do you use ‘gtf’ ?
I can’t find this package anywhere…


(Erin) #7

In Debian it appears to be in xserver-xorg-core


#8

@Erin You’re right, I can see it in the filelist

However I can’t find it in the Void’s xorg packages.
Does anyone know where it is ?


#9

xorg-server template
Line 12

--disable-xfree86-utils

#10

ok I see it! so this option is disabled in Void,
but this is not the default setting:

$ ./configure --help

  --enable-xfree86-utils  Build xfree86 DDX utilities (default: enabled)

(Bruno de Souza Lino) #11

In Arch, they seem to be part of the ‘xorg-xrandr’ package.


#12

I will post once: Solve bad EDID at lower levels. Define an EDID blob or video mode at boot with kernel parameters (via dracut). The nouveau driver has its own kernel parameters. Also try the read-edid package.


#13

If this flag is enabled in Debian and Arch, why not in Void ?
#8900


(Bruno de Souza Lino) #14

@nixit
I can’t do that. The EDID is not even the one that the monitor should come with. It’s a rebranded 19" LG Flatron W1942S, but it seems to be using the 21" firmware, which has resolutions this monitor can’t display at all. I tried finding the EDID before, but couldn’t find it or it was hidden behind paywalls. Also, I don’t have the knowledge of writing it either.

As per booting with ‘nomodeset’, the kernel spits “No UMS mode in radeon module”.


#15

@CrimSun the pull request to enable xfree86-utils in xorg-server has been accepted and merged. The package will soon be updated.
Tell us if it helps you.


#16

You can just compile that: http://www.uruk.org/projects/cvt/
xbps-install gcc
wget http://www.uruk.org/projects/cvt/cvt.c
gcc cvt.c -O2 -o cvt -lm -Wall

It will create cvt binary:
./cvt

Description: This program generates video timing descriptions using formulas
from the VESA “CVT” (Coordinated Video Timing) v1.1 specification, based
itself on the earlier VESA “GTF” (Generalized Timing Formula) v1.0
specification.

usage: ./cvt x y refresh [-v|–verbose]
[-r|–reduced-blank] [-i|–interlaced]
[-f|–fbmode] [-x|-xf86mode]

       x : the desired horizontal resolution (required)
       y : the desired vertical resolution (required)
 refresh : the desired refresh rate (required)

-v|–verbose : enable verbose printouts (traces each step of the computation)
-r|–reduced-blank : use “Reduced Blanking” timings
-i|–interlaced : generate an Interlaced video mode
-f|–fbmode : output an fbset(8)-style mode description
-x|-xf86mode : output an XFree86-style mode description (this is the default
if no mode description is requested)

That how you can set it up in xorg conf file: /etc/X11/xorg.conf.d/20-monitor.conf : http://sprunge.us/fZTf


#17

You disabled KMS. I said use it. Ditch nomodeset, hardwire a mode in dracut kernel params, and disable EDID in X confs via UseEDID and UseEDIDFreqs set false. I already linked refs and another has “Forcing Modes” (bottom).

A monitor firmware u/g may fix your EDID. LG fixes are not paywalled, if geowalled. They run on Windows. I found three variants of model W1942S at

You can repair EDID in Linux by hand.


(Bruno de Souza Lino) #18

@NOTMY Even if I could do that, xrandr still doesn’t work, otherwise I’d build gtf and cvt from source. Well, if xrandr worked, gff and cvt would as well, since they are part of the same package.

@nixit I’ll take a look at that. Thanks.


#19

Please look at my last line in previous post with example how to set it up probably without installing xrandr and just by xorg configuration.


(Bruno de Souza Lino) #20

@NOTMY Well, I’m checking the service manual of the monitor and…there’s two refresh rates (H - Pixels and V - Lines), I’m not sure which one to use or to pass to gtf.