Home | News | Download | Packages | Forum | Wiki | Github

Last Kernel and Internet


(mr. j) #21

I have the same hardware. First, you need to install the linux-firmware-network package in order to use the ath10k firmware blob for your wireless network card, then run xbs-reconfigure -f linux$(VERSION) and dracut --force to regenerate your kernel and initramfs. Second, remove any network related service from /var/service/ like NetworkManager,connman,wpa_supplicant,dhcpcd. Then create and add this file /etc/sv/dhcpcd-wlp58s0/run

`
#!/bin/sh

exec dhcpcd -B wlp58s0 1>&2
`

and assign permission 755 to the file, Finally symlink it to the services directory and restart your computer.
In order to connect to a nertwork, you need to add the network info to /etc/wpa_supplicant/wpa_supplicant.conf
NOTE: wlp58s0 is the name of your wireless card


(kny) #22

Well, so I already had the linux-firmware-network package installed (without it, nothing works).
I reconfigure the last kernel as written xbps-reconfigure ... dracut ...
I removed any network related service from /var/service/. So just the dhcpcd service.
And I create the /etc/sv/dhcpcd-wlp58s0/run file (I have the same card name of course)
I have all the networks infos in /etc/wpa_supplicant/wpa_supplicant-wlp58s0.conf.
And I have a conf file in /etc/sv/dhcpcd-wlp58s0/ with OPTS="-M --opt".
I reboot.
Same problem.
I lost the network connection after some minutes and I have to restart the dhcpcd service manually.

Maybe another idea ?


#23

Maybe related ?
The BIOS update for your machine is marked as Urgent by Dell (released 25 Oct 2017).


(kny) #24

My BIOS is already up-to-date.


#25

I meant: start the dhcpcd daemon from the command line, to see which errors are displayed on the screen…


(mr. j) #26

You don’t need to have that conf file in /etc/sv/dhcpcd-wlp58s0/.

Do you have the following lines in your wpa_supplicant.conf file?

ctrl_interface=/run/wpa_supplicant
ctrl_interface_group=wheel
eapol_version=1
ap_scan=1
fast_reauth=1
update_config=1

Or just maybe, add yourself to the network group.


(kny) #27

@cr6
Do you mean as sv stop dhcpcd-wlp58s0 then sv start dhcpcd-wlp58s0
Or sv stop dhcpcd-wlp68s0 then killall dhcpcd and finally dhcpcd wlp58s0

A - no errors
B - From terminal
wlp58s0: starting wpa_supplicant
wlp58s0: waiting for carrier
wlp58s0: carrier acquired
wlp58s0: rebinding lease of 192.168.0.25
wlp58s0: leased 192.168.0.25 for 43200 seconds
wlp58s0: adding route to 192.168.0.0/24
wlp58s0: adding default route via 192.168.0.254
forked to background, child pid 8881
(I just removed the IP and MAC address)
From dmesg :
[ 7437.785356] ath10k_pci 0000:3a:00.0: Unknown eventid: 90118
And after the same as terminal
Then [ 7442.808618] IPv6: ADDRCONF(NETDEV_CHANGE): wlp58s0: link becomes ready

@spartan117
Yes I have all these lines in the wpa_supplicant.conf file.


#28

No, just run dhcpcd directly from the command line, as you do for any other program…

Look at /etc/sv/dhcpcd/run

This is what runit is actually doing to start the daemon.


(kny) #29

It is exactly what I did


(mr. j) #30

You said that you had the conf file in /etc/wpa_supplicant/wpa_supplicant-wlp58s0.conf so make sure that is in there, and remove the conf file from the dhcpcd-wlp58s0.


#31

Yes! I was distracted… sorry. :wink:

:slightly_smiling_face: good !

Okay, just wait until an error is displayed ? :stopwatch:


(kny) #32

@spartan117
I have it in the both default one and -wlp58s0 one.

@cr6
I had many cut, but no error messages.


#33

Could it be firmware related ?
The Void meta-package linux-firmware is dated 2017-06-22, a bit old.

Looking at linux-firmware.git, I can see this commit related to your issue with your network adapter Atheros QCA6174:

Update from a new firmware branch. This also fixes a regression with ath10k
frequently disconnecting:

http://lists.infradead.org/pipermail/ath10k/2017-August/010062.html

It’s time to update our package. :wilted_flower:


(kny) #34

You seem to have found the problem.
So I just have to wait an update from the void repositories, right ?


#36

Not long ago, I suggested it in #8113.

@kny I reported the issue on github. :wink:


(kny) #37

Thank you. I saw your report, and it seems they resolve a problem, but with another package, so it doesn’t change anything for me.
The package is still the old one.


#38

@kny Have you seen #9687 ?


(kny) #39

Ahah, I got the update exactly at the same time as your reply :slight_smile:
I will check it and will update if it’ll solved everything.

[UPDATE]
updated the package, everything is ok now !
Problem solved !
Thanks !