Home | News | Download | Packages | Forum | Wiki | Github

Last Kernel and Internet


(kny) #1

With the last kernels (4.12.9 —> 4.12.12), I have some troubles with my WiFI.
From the 4.12.9 to the 4.12.11, I have no connection at all. With the last one (4.12.12), I lost the connection randomly. I have to restart the dhcpcd sv each 20 minutes.
Everything is ok with the previous kernel (4.11.11).

Any idea ?


#2

Do use a module for your hardware? E.g. broadcom-wl-dkms or the like?


(kny) #3

I don’t remember.
How can I check it ?

I have 2 firmware installed :
ipw2100-firmware and ipw2200-firmware


#4

Maybe a better question is, what is your hardware? Use lspci and look for anything named wireless, wlan or network or so.

And maybe try looking for packages name containing wl or dkms.

xbps-query -Rs wl
xbps-query -Rs dkms
xbps-query -Rs void-repo-nonfree

Also, it’s a wild guess, but I remember I actually had a similar issue when using both dhcpcd and wpa_supplicant services, because of a recent change.


(kny) #5

the lspci command returns Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)
(I have a Dell XPS 13 9360)

for the xbps-query commands, I have none of wl or dkms packages installed.
I remember that my Wireless card is out-of -the-box ready.

Your guess is probably a good one, because the issue appears only when the kernel changes.
Do you use something else than dhcpcd and wpa_supplicant ?


#6

sudo rm /var/service/wpa_supplicant

This will probably solve your problem.
Something about an update to dhcpcd and eternal service wars about the wireless card.


(kny) #7

Can I keep the wpa_supplicant config file of the network ?


#8

That depends. Does its filename match what dhcpcd looks for in /usr/share/dhcpcd/hooks/10-wpa_supplicant?

Alternatively, you can do what I did, which respects any strange changes you made to wpa_supplicant config. Be sure to also keep the wpa_supplicant service enabled.


(kny) #9

I was talking about the wpa_supplicant-<device_name>.conf that the wiki and wpa_supplicant advise to create for the networks configurations.


#10

I just symlinked my config to wpa_supplicant.conf. Don’t know if it’s update proof, but it works for now.


(kny) #11

@ivierlin I have no wpa_supplicant in /var/service/
@volleyper and I have no config directory in /etc/dhcpcd/conf
I suppose I have to create it ?


#12

That means you probably have a different issue from me and @ivierlin, unless you start wpa_supplicant manually or in something like /etc/rc.local. Do you still have no problems with the 4.11 kernel?


(kny) #13

My /etc/rc.local is empty. And I still have no problems with the 4.11 kernel.


#14

Then it seems to me this is a kernel bug. What about linux4.13? Do you use musl? Also maybe try regenerating the initramfs for4.12:

# xbps-reconfigure -f linux4.12

(kny) #15

I tried the last 4.13 too. Same issue.
I do not use musl.
I will try your command line, for 4.12 and 4.13


#16

I’ve had some weird dhcpcd issues on my laptop lately, not sure if it is related.


(kny) #17

Well, I need some help.

I tried to reconfigure as @volleyper suggeted to me with xbps-reconfigure -f linux4.13
And my /etc/rc.local is still empty.

I do not know what to do to have Internet.

I tried the last version of the kernel, but the problem remains.


#18

No, this is not what he told you:


You could try to manually start the dhcpcd daemon, to see what happens in your system…


(kny) #19

But I have no conf file in /etc/sv/dhcpcd/


(maxice8's favorite salad) #20

One can be just created and assigned variables that affect the run file

echo "OPTS=\"-M --opt\"" > /etc/sv/dhcpcd/conf