Kernel panic on 4.15


#21

well, i’ve been trying each new 4.16 kernel as they come out, but no change…
looking at the error message(what i can see of it), it ends with: [sic]

kernel panic    not syncing   fatal exception in interrupt

i went looking in the void-packages/srcpkgs/linux4.16/files/x86_64-dotconfig
and compared it with the linux4.14 one…
unsurprisingly, there are many differences… but i did notice these, with ‘syncing’ in mind:
+CONFIG_ARCH_HAS_MEMBARRIER_SYNC_CORE=y
+CONFIG_ARCH_HAS_SYNC_CORE_BEFORE_USERMODE=y
these are in 4.16 but not 4.14


#22

These were not present in 4.14, see for reference:


#23

I had a similar issue on some Compaq Elite 8300 units and Ubuntu a few months back. The solution I found was to move away from a UEFI install and do a BIOS/MBR style install instead.

More info: https://ubuntuforums.org/showthread.php?t=2383405

Are you running a UEFI or “legacy” boot environment?

[Generally speaking I recommend avoiding UEFI as much as possible anyway, but that’s a discussion for another day]


#24

BIOS/MBR, this is an oldish laptop circa 2010ish (asus N61J i7 radeon 5730)
it has an early uefi implementation, but i’ve never used it…
the 4.16.3 kernel(with aufs patch) from porteus runs and shuts down fine on it…


#25

UPDATE: After a long time, i finally “solved” my issue, but i will need help to fix/understand better, here what is happening on my PC:

The main problem is when i kill my X process, exactly when Xorg close his log file, yep, the problem is on closing the /var/log/Xorg.0.log, happens that my user only have read permissions:

-rw-r--r-- 1 root user 34K Jun 8 19:03 Xorg.0.log

So, adding a write permission with chmod 664 fixed the Kernel Panic, but i still wondering, what really happened? the kernel shouldn’t give enough permissions to the Xorg process? i dont have that problem on any kernel below 4.15.

My temporary solution while i’m studyng that error, is put the chmod on /etc/runit/3 file, before the killing process line.

Also, i start my X server directly from the shell, using startx only, i dont use any login/session manager.


#26

-rw-r–r-- 1 root user 34K Jun 8 19:03 Xorg.0.log

This line says that you have both read and rewrite permissions for this file. The ‘rw’ at the beginning. Is this a mistake?

My temporary solution while i’m studyng that error, is put the chmod on /etc/runit/3 file, before the killing process line.

Side thought: this might even be a timing related issue. What happens of you add ‘sleep 3’ there instead of chmod?


#27

This line says that you have both read and rewrite permissions for this file. The ‘rw’ at the beginning. Is this a mistake?

My user only have read permission, i dont run X with root

Side thought: this might even be a timing related issue. What happens of you add ‘sleep 3’ there instead of chmod?

I don’t think so, the panic happens even i only close my graphical interface, without turn off, my another “fix” was use lxdm to manage my session, now Xorg is a son proccess of lxdm and no panic happened anymore.

Also, with lxdm a noticed that my Xorg file now have only root as file owner, as lxdm is a runit service, i believe that’s give enough permission to manage everything, probably run startx with my regular user was the problem ?.

My user groups are
wheel audio video

EDIT 1: I still don’t get how a permission issue leads a kernel panic


(Erin) #28

My Xorg.0.log file has the same permissions except “user” is my username.


#29

That’s strange, using a session manager(lxdm) fixed for me, but i believe the real problem still not fixed.


#30

yep, not a fix for me. i’ve been using lxdm the whole time…


#31

I have the same problem and changing the permission did not work for me. But in the lts kernel this does not occur.


#32

i’m wondering what is the biggest changes between 4.14 and 4.15, i looked on code but i cant find anything that can lead a kernel panic on my machine.

There is a way to use something like gdb or any debugger on kernel?